Initial questions

Theo Markettos theom+rotex at
Fri Feb 3 21:30:38 GMT 2012

On Fri, Feb 03, 2012 at 08:11:09PM +0000, David R Lane wrote:
> I have had a look at the Latex software and have managed to get a DVI 
> file from a text file input and viewed the DVI output in DVIview.
> I have version 3.1 of armTeX, version 1.03 of DVIview and version 1.30 
> of TeXFonts all of November 2004.
> Are there later versions of any of these and, if so, where?

Those sound fairly recent to me.  I don't think anything has happened to TeX
on RISC OS since then.  I did have a go at cross-compiling tetex, but it
turned into a hugely complex project because the build system wasn't
amenable.  TeXLive (its replacement) may be more amenable, I haven't tried it.

> The riscos-tex Archives at 'chiark.greenend' are empty. Are past posts 
> to the email list somewhere else?

The server had a backup failure in the summer, so I'm afraid they're gone. 
The list has been effectively dead for some years.

> The "Edit paper sizes ...." item on the iconbar menu of DVIview seems 
> stuck on size A2, setting other sizes is not retained. Also the A4 
> width and height are incorrect, giving the same figures as for A2.

Pass, I don't know anything about DVIview.

> When I double click on my Latex directory with all the software in it, 
> including !TeXFonts, I get an error message titled
> Run ADFS::HardDisc4.$........Latex.!TeXFonts.!Boot
> and saying
> "Repeat: Font prefix is not a path.
> Press SPACE or click mouse to continue."
> After clicking this away, the filer window of the directory appears 
> and I can proceed. Is this to be expected?

!TeXFonts.!Boot is running all the !Install scripts in

Something is going wrong on one of them, but it's difficult to tell which
one.  You could try moving some out of the way and seeing which it is.  I
think one of the FontInstall lines in one of them is the problem.

> Finally, to produce the DVI file I use command line, but would like to 
> be able to use the WIMP as it claims you can in the help inside !TeX.
> The directions in this readMe don't work for me.

You should be able to double click a (La)TeX file to process to DVI, though
it's been ages since I tried this.  What happened?


More information about the riscos-tex mailing list