PuTTY bug ki-multiprompt-crash

Home | FAQ | Feedback | Licence | Updates | Mirrors | Keys | Links | Team
Download: Stable · Snapshot | Docs | Changes | Wishlist

summary: Crash with SSH keyboard-interactive packet with multiple prompts
class: bug: This is clearly an actual problem we want fixed.
difficulty: tricky: Needs many tuits.
priority: high: This should be fixed in the next release.
absent-in: 0.57
present-in: 0.58 2005-05-11
fixed-in: 2005-10-31 8719f92c1426609de7ead4a490a15d1d18875f53 (0.59)

In an SSH-2 session, if PuTTY is presented with a single `keyboard-interactive' packet containing multiple prompts, it will crash after the first prompt. This only affects PuTTY proper; the non-GUI tools (PSCP, PSFTP, Plink) should work fine.

This problem has the same root cause as `ssh1-bad-passphrase-crash', and should be fixed by the same rearrangement.

Update, 2005-10-31: I believe this should now be fixed, and we've had one report confirming that.


If you want to comment on this web site, see the Feedback page.
Audit trail for this bug.
(last revision of this bug record was at 2016-12-27 11:40:22 +0000)