chiark / gitweb /
svc/watch.in: Bug fix: addpeer on correct coroutine.
[tripe] / debian / tripe.postinst
index 311664a80e9cdb639c24e453a12d2b0a8c1f716e..2994690257f4bdb6f5d4e83fed9848f16b2cb914 100644 (file)
@@ -2,13 +2,24 @@
 
 set -e
 
-if [ ! -c /dev/.devfsd ] && [ ! -c /dev/net/tun ]; then
+## Make sure that /dev/net/tun exists.  Don't do anything special if devfs or
+## udev is running.
+if [ ! -c /dev/.devfsd ] &&
+   [ ! -d /dev/.udev ] &&
+   [ ! -c /dev/net/tun ]
+then
+  echo "/dev/net/tun not present: invoking MAKEDEV to create it."
   (cd /dev && /sbin/MAKEDEV tun)
 fi
 
-#DEBHELPER#
+## Make sure that the `tripe' user and group exist.
+getent group tripe >/dev/null ||
+       addgroup --system tripe
+getent passwd tripe >/dev/null || \
+       adduser --system \
+               --ingroup tripe \
+               --home /etc/tripe \
+               --gecos "TrIPE server" \
+               tripe
 
-if [ -x "/etc/init.d/tripe" ]; then
-  update-rc.d tripe defaults >/dev/null
-  invoke-rc.d tripe start
-fi
+#DEBHELPER#