chiark / gitweb /
configure.ac, debian/: Overhaul Wireshark plugin build machinery.
[tripe] / debian / control
index 615e021a0837ff33987ac98f555344484fbe0361..b11909b64fbd7739bf3786df625e53ccda63728f 100644 (file)
@@ -2,13 +2,19 @@ Source: tripe
 Section: net
 Priority: extra
 Maintainer: Mark Wooding <mdw@distorted.org.uk>
-Build-Depends: catacomb-dev (>= 2.1.0), mlib-dev (>= 2.0.3),
- tshark, wireshark-dev (>= 0.10.10), debhelper (>= 4.0.2)
+XS-Python-Version: >= 2.4
+Build-Depends: debhelper (>= 9), pkg-config, curl, rsync, python-central,
+       tshark, wireshark-dev (>= 1.12.1),
+       mlib-dev (>= 2.2.2),
+       catacomb-dev (>= 2.2.2+38), catacomb-bin (>= 2.1.4)
+Build-Depends-Indep: python,
+       python-cdb, python-gtk2,
+       python-mlib (>= 1.0.2), python-catacomb (>= 1.1.0)
 Standards-Version: 3.1.1
 
 Package: tripe
 Architecture: any
-Depends: ${shlibs:Depends}, sysvinit (>= 2.80-1), makedev (>= 2.3.1-63)
+Depends: ${shlibs:Depends}, makedev (>= 2.3.1-63) | udev, adduser
 Recommends: catacomb-bin
 Suggests: pkstream
 Description: Trivial IP Encryption: a simple virtual private network
@@ -22,16 +28,35 @@ Description: Trivial IP Encryption: a simple virtual private network
 Package: pkstream
 Architecture: any
 Depends: ${shlibs:Depends}
-Suggests: fw | ssh | stunnel
+Suggests: fwd | ssh | stunnel
 Description: Forward UDP packets over a stream
  Pkstream is a simple program which transmits and receives UDP datagrams
  over a reliable stream.  By default, it will send and receive the
  packets on standard input and output; it also natively understands TCP
  sockets.  Anything else can probably be fudged up with a port forwarder.
 
+Package: pathmtu
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Discover the path MTU to a given host
+ Pathmtu is a simple utility which prints the path MTU to a given host, i.e.,
+ the size of the largest IP packet which can be sent to the host without
+ needing to be fragmented.
+
+Package: tripe-uslip
+Architecture: any
+Depends: ${shlibs:Depends}
+Recommends: tripe
+Description: Trivial IP Encryption: a simple virtual private network
+ TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
+ and authenticity of packets it sends and receives.
+ .
+ The tripe-uslip tool provides a fake SLIP tunnel which can be driven from
+ scripts and is useful for testing.  `If in doubt, say N here.'
+
 Package: tripe-wireshark
 Architecture: any
-Depends: ${shlibs:Depends}, wireshark-common (= ${tripe:Wireshark-Version})
+Depends: wireshark-common (= ${tripe:Wireshark-Version}), ${shlibs:Depends}
 Description: Trivial IP Encryption: a simple virtual private network
  TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
  and authenticity of packets it sends and receives.
@@ -52,7 +77,8 @@ Description: Trivial IP Encryption: a simple virtual private network
 
 Package: tripemon
 Architecture: all
-Depends: python (>= 2.3), python-gtk2 (>= 2.6), tripe
+Depends: python (>= 2.4), python-gtk2 (>= 2.6),
+       python-mlib (>= 1.0.2), tripe, python-tripe
 Description: Trivial IP Encryption: a simple virtual private network
  TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
  and authenticity of packets it sends and receives.
@@ -60,9 +86,40 @@ Description: Trivial IP Encryption: a simple virtual private network
  This package contains a graphical monitor program for managing and
  keeping an eye on a TrIPE server.
 
+Package: python-tripe
+Architecture: all
+Depends: ${python:Depends}, python-mlib (>= 1.0.2), tripe
+Recommends: python-codespeak-lib
+XB-Python-Version: ${python:Versions}
+Description: Trivial IP Encryption: a simple virtual private network
+ TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
+ and authenticity of packets it sends and receives.
+ .
+ This package contains Python modules for communicating with the tripe
+ server.
+ .
+ The package python-codespeak-lib provides an efficient implementation of
+ coroutines (`greenlets') used by these modules.  An inefficient
+ implementation, based on threads, is included, so small sites can probably
+ manage without.
+
+Package: tripe-peer-services
+Architecture: all
+Depends: python (>= 2.4), python-cdb, iproute, python-mlib (>= 1.0.2),
+       tripe, python-tripe, pathmtu
+Description: Trivial IP Encryption: a simple virtual private network
+ TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
+ and authenticity of packets it sends and receives.
+ .
+ This package contains services for managing connections with peers:
+ .
+ connect       Register named peer correctly
+ watch         Configure interface and wake up remote end when peer arrives
+
 Package: tripe-keys
 Architecture: all
-Depends: python (>= 2.3), tripe, catacomb-bin, python-catacomb
+Depends: python (>= 2.4), curl, tripe,
+       catacomb-bin, python-catacomb (>= 1.1.0)
 Description: Trivial IP Encryption: a simple virtual private network
  TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
  and authenticity of packets it sends and receives.