chiark / gitweb /
debian/: Update for Debhelper 10.
[tripe] / debian / rules
index 01625b27fa5aafbd3ebf927508eaaa3be848b74c..9b5065a32ff51befd150d7b5cb74b2f226b00c5c 100755 (executable)
@@ -1,6 +1,6 @@
 #! /usr/bin/make -f
 
-DH_OPTIONS              = --parallel -Bdebian/build
+DH_OPTIONS              = -Bdebian/build
 
 ###--------------------------------------------------------------------------
 ### Configuration.
@@ -9,6 +9,7 @@ OVERRIDES               += auto_configure
 dh_auto_configure_OPTS  = --
 
 ## Various files and directories.
+dh_auto_configure_OPTS += --libdir="\$${prefix}/lib"
 dh_auto_configure_OPTS += --libexecdir="\$${libdir}/tripe"
 dh_auto_configure_OPTS += --with-configdir="/etc/tripe"
 dh_auto_configure_OPTS += --with-socketdir="/var/run"
@@ -28,9 +29,6 @@ dh-gencontrol-hook::
                sed -n 's/^Version: */tripe:Wireshark-Version=/p' \
                >> debian/tripe-wireshark.substvars
 
-OVERRIDES              += shlibdeps
-dh_shlibdeps_OPTS      += -Xwireshark/plugins
-
 ###--------------------------------------------------------------------------
 ### The startup script and related machinery.
 
@@ -64,7 +62,7 @@ dh-install-hook::
 ###--------------------------------------------------------------------------
 ### Some machinery for overriding Debhelper in a structured way.
 
-%:; dh $@ $(DH_OPTIONS)
+%:; dh $@ --without autoreconf $(DH_OPTIONS)
 
 $(foreach o, $(sort $(OVERRIDES)), dh-$o-hook)::; @:
 $(foreach o, $(sort $(OVERRIDES)), override_dh_$o): override_dh_%: dh-%-hook