chiark / gitweb /
Add notion of `ephemeral' associations and a goodbye protocol.
[tripe] / debian / rules
index b45a6be5e7aad9b12cf94edd4fa3bfe1abd83bb6..0822dce1082e2cc4ff4120c01a1ab805663c96f5 100755 (executable)
@@ -9,6 +9,7 @@ OVERRIDES               += auto_configure
 dh_auto_configure_OPTS  = --
 
 ## Various files and directories.
+dh_auto_configure_OPTS += --libdir="\$${prefix}/lib"
 dh_auto_configure_OPTS += --libexecdir="\$${libdir}/tripe"
 dh_auto_configure_OPTS += --with-configdir="/etc/tripe"
 dh_auto_configure_OPTS += --with-socketdir="/var/run"
@@ -47,9 +48,9 @@ dh-clean-hook::
 ### Other things.
 
 ## Python stuff.
-DH_OPTIONS             += --with=python-central
-OVERRIDES              += pycentral
-dh_pycentral_OPTS      += -ppython-tripe
+DH_OPTIONS             += --with=python2
+OVERRIDES              += python2
+dh_python2_OPTS                += -ppython-tripe
 
 ## The peer database.
 OVERRIDES              += install