chiark / gitweb /
Make `tripe' be the default key type.
[tripe] / debian / rules
index e48ae0731382fa8a88bdaca47d74d8d32e5f0b25..0a422e834aa2651b19a83c2aa9ed068b79f8bcfd 100755 (executable)
@@ -9,6 +9,7 @@ include $(CDBS)/class/autotools.mk
 ### General settings.
 
 DEB_BUILDDIR = $(CURDIR)/build
+DEB_MAKE_CHECK_TARGET = check
 
 ###--------------------------------------------------------------------------
 ### Correct configuration.
@@ -26,6 +27,12 @@ DEB_CONFIGURE_EXTRA_FLAGS = \
        --with-initconfig="/etc/default/tripe" \
        --with-wireshark
 
+###--------------------------------------------------------------------------
+### Python.
+
+binary-install/python-tripe::
+       dh_pycentral -ppython-tripe
+
 ###--------------------------------------------------------------------------
 ### Install the startup scripts.
 
@@ -36,6 +43,13 @@ install/tripe::
 cleanbuilddir::
        rm -f debian/tripe.init debian/tripe.default
 
+###--------------------------------------------------------------------------
+### Install configuration files.
+
+install/tripe-peer-services::
+       install -m644 $(DEB_SRCDIR)/peerdb/peers.in \
+               debian/tripe-peer-services/etc/tripe/peers.d/10base
+
 ###--------------------------------------------------------------------------
 ### Wireshark plugin.