chiark / gitweb /
server/peer.c: Handle mobile peers switching addresses.
[tripe] / debian / control
index ef4865cbacc2b0d888462187849a11bede705eaf..2c4d258101ce5cd3c6a9205278198795d39552dd 100644 (file)
@@ -1,21 +1,23 @@
 Source: tripe
 Section: net
 Priority: extra
-Maintainer: Mark Wooding <mdw@nsict.org>
-Build-Depends: catacomb-dev (>= 2.1.0), mlib-dev (>= 2.0.3),
- tethereal, ethereal-dev (>= 0.10.10), debhelper (>= 4.0.2)
+Maintainer: Mark Wooding <mdw@distorted.org.uk>
+XS-Python-Version: >= 2.4
+Build-Depends: catacomb-dev (>= 2.1.1), mlib-dev (>= 2.0.4),
+ tshark, wireshark-dev (>= 0.10.10), debhelper (>= 4.0.2),
+ python-central
 Standards-Version: 3.1.1
 
 Package: tripe
 Architecture: any
-Depends: ${shlibs:Depends}, sysvinit (>= 2.80-1), makedev (>= 2.3.1-63)
+Depends: ${shlibs:Depends}, makedev (>= 2.3.1-63) | udev, adduser
 Recommends: catacomb-bin
 Suggests: pkstream
 Description: Trivial IP Encryption: a simple virtual private network
  TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
  and authenticity of packets it sends and receives.
  .
- This package contains the main daemon, support programs, and documentation. 
+ This package contains the main daemon, support programs, and documentation.
  It ideally wants a 2.4 series kernel with the TUN/TAP driver enabled, but
  it will work with any kernel which speaks SLIP.
 
@@ -27,20 +29,51 @@ Description: Forward UDP packets over a stream
  Pkstream is a simple program which transmits and receives UDP datagrams
  over a reliable stream.  By default, it will send and receive the
  packets on standard input and output; it also natively understands TCP
- sockets.  Anything else can probably be fudged up with port forwarder.
+ sockets.  Anything else can probably be fudged up with port forwarder.
 
-Package: tripe-ethereal
+Package: pathmtu
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Discover the path MTU to a given host
+ Pathmtu is a simple utility which prints the path MTU to a given host, i.e.,
+ the size of the largest IP packet which can be sent to the host without
+ needing to be fragmented.
+
+Package: tripe-uslip
+Architecture: any
+Depends: ${shlibs:Depends}
+Recommends: tripe
+Description: Trivial IP Encryption: a simple virtual private network
+ TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
+ and authenticity of packets it sends and receives.
+ .
+ The tripe-uslip tool provides a fake SLIP tunnel which can be driven from
+ scripts and is useful for testing.  `If in doubt, say N here.'
+
+Package: tripe-wireshark
 Architecture: any
-Depends: ${shlibs:Depends}, ethereal-common (= ${tripe:Ethereal-Version})
+Depends: wireshark-common (= ${tripe:Wireshark-Version}), ${shlibs:Depends}
+Description: Trivial IP Encryption: a simple virtual private network
+ TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
+ and authenticity of packets it sends and receives.
+ .
+ This package contains the protocol analysis plug-in for Wireshark (the new
+ name for Ethereal).
+
+Package: tripe-ethereal
+Architecture: all
+Depends: tripe-wireshark
 Description: Trivial IP Encryption: a simple virtual private network
  TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
  and authenticity of packets it sends and receives.
  .
- This package contains the protocol analysis plug-in for Ethereal.
+ This is a dummy package to ease the transition to tripe-wireshark (since
+ Wireshark is apparently the new name for Ethereal).  You should probably
+ remove this package.
 
 Package: tripemon
 Architecture: all
-Depends: python (>= 2.3), python-gtk2 (>= 2.6), tripe
+Depends: python (>= 2.4), python-gtk2 (>= 2.6), tripe
 Description: Trivial IP Encryption: a simple virtual private network
  TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
  and authenticity of packets it sends and receives.
@@ -48,9 +81,39 @@ Description: Trivial IP Encryption: a simple virtual private network
  This package contains a graphical monitor program for managing and
  keeping an eye on a TrIPE server.
 
+Package: python-tripe
+Architecture: all
+Depends: ${python:Depends}, python-mlib, tripe
+Recommends: python-codespeak-lib
+XB-Python-Version: ${python:Versions}
+Description: Trivial IP Encryption: a simple virtual private network
+ TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
+ and authenticity of packets it sends and receives.
+ .
+ This package contains Python modules for communicating with the tripe
+ server.
+ .
+ The package python-codespeak-lib provides an efficient implementation of
+ coroutines (`greenlets') used by these modules.  An inefficient
+ implementation, based on threads, is included, so small sites can probably
+ manage without.
+
+Package: tripe-peer-services
+Architecture: all
+Depends: python (>= 2.4), python-mlib, tripe, python-cdb, python-tripe,
+       pathmtu, iproute
+Description: Trivial IP Encryption: a simple virtual private network
+ TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
+ and authenticity of packets it sends and receives.
+ .
+ This package contains services for managing connections with peers:
+ .
+ connect       Register named peer correctly
+ watch         Configure interface and wake up remote end when peer arrives
+
 Package: tripe-keys
 Architecture: all
-Depends: python (>= 2.3), tripe, catacomb-bin, python-catacomb
+Depends: python (>= 2.4), tripe, catacomb-bin, python-catacomb
 Description: Trivial IP Encryption: a simple virtual private network
  TrIPE is a simple VPN protocol.  It uses cryptography to ensure secrecy
  and authenticity of packets it sends and receives.