chiark / gitweb /
doc/concepts.tex: Typeset method rĂ´le names as identifiers.
[sod] / debian / rules
index cec98bbefd3fecee9c600823051662e275a37f25..db3d0304c4bb975f3dae295ee18b2c017cb9c224 100755 (executable)
@@ -1,2 +1,15 @@
 #! /usr/bin/make -f
 %:; dh $@ --parallel -Bdebian/build
+
+## The `sbuild' tool sets a fake `home' directory which doesn't exist.  This
+## breaks ASDF, which wants to write FASL files into `~/.cache/common-lisp/'.
+## Set an explicit cache directory for it, and clear away the FASL cache
+## directory on clean.
+export XDG_CACHE_HOME := $(shell pwd)/debian/build/cache
+override_dh_auto_clean:
+       dh_auto_clean
+       rm -rf debian/build/cache
+
+## Don't strip the main executable.  (It doesn't work, and you get left with
+## a bare SBCL.)
+override_dh_strip:; dh_strip -Xusr/bin/sod