chiark / gitweb /
build, debian/: Add a `configure' script to make things easier.
[preload-hacks] / debian / rules
index 81d3e4b9bd17bf84f6d2ae37652b4a62f18b7257..22e825d5ddf296ee9744610c2af61bf75113f633 100755 (executable)
@@ -1,11 +1,9 @@
 #! /usr/bin/make -f
 
-arch = $(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)
+DH_OPTIONS              = --parallel -Bdebian/build
 
-%:; dh $@ --parallel
+%:; dh $@ $(DH_OPTIONS)
 
-override_dh_auto_install:
-       dh_auto_install --parallel -- \
-               prefix=/usr mandir=/usr/share/man \
-               libdir=/usr/lib/$(arch) \
-               DESTDIR=debian/tmp
+override_dh_auto_configure:
+       dh_auto_configure $(DH_OPTIONS) -- \
+               $(shell dpkg-buildflags --export=cmdline)