chiark / gitweb /
noip.c: Add debugging to most of the syscall wrappers.
[preload-hacks] / debian / rules
index 3d2464872fb328aefe6f2b6f884513e7837a196c..81d3e4b9bd17bf84f6d2ae37652b4a62f18b7257 100755 (executable)
@@ -1,11 +1,11 @@
 #! /usr/bin/make -f
 
-CDBS = /usr/share/cdbs/1
+arch = $(shell dpkg-architecture -qDEB_BUILD_MULTIARCH)
 
-include $(CDBS)/rules/debhelper.mk
-include $(CDBS)/class/makefile.mk
+%:; dh $@ --parallel
 
-DEB_MAKE_CLEAN_TARGET = clean
-DEB_MAKE_INSTALL_TARGET = install \
-       prefix=/usr mandir=/usr/share/man \
-       DESTDIR=debian/tmp
+override_dh_auto_install:
+       dh_auto_install --parallel -- \
+               prefix=/usr mandir=/usr/share/man \
+               libdir=/usr/lib/$(arch) \
+               DESTDIR=debian/tmp