chiark / gitweb /
debian/rules: Use old-fashioned `dpkg-buildflags' options.
[preload-hacks] / debian / rules
index 3d2464872fb328aefe6f2b6f884513e7837a196c..d780d0e7151480a3254c074072c244bb3df5b564 100755 (executable)
@@ -1,11 +1,9 @@
 #! /usr/bin/make -f
 
-CDBS = /usr/share/cdbs/1
+DH_OPTIONS              = --parallel -Bdebian/build
 
-include $(CDBS)/rules/debhelper.mk
-include $(CDBS)/class/makefile.mk
+%:; dh $@ $(DH_OPTIONS)
 
-DEB_MAKE_CLEAN_TARGET = clean
-DEB_MAKE_INSTALL_TARGET = install \
-       prefix=/usr mandir=/usr/share/man \
-       DESTDIR=debian/tmp
+override_dh_auto_configure:
+       dh_auto_configure $(DH_OPTIONS) -- \
+               $(shell dpkg-buildflags --export=configure)