chiark / gitweb /
Debianize new mup version
[mup] / mup / debian / rules
diff --git a/mup/debian/rules b/mup/debian/rules
new file mode 100755 (executable)
index 0000000..ea1b85e
--- /dev/null
@@ -0,0 +1,45 @@
+#! /usr/bin/make -f
+
+export DH_COMPAT = 4
+
+clean:
+       dh_testdir
+       dh_clean
+       make clobber
+       rm -f build
+
+build:
+       make
+       touch build
+
+install: build
+       dh_clean
+       make install PREFIX=`pwd`/debian/tmp/usr
+       dh_install --sourcedir=debian/tmp
+
+binary-indep: install
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
+
+binary-arch: install
+       dh_testdir -a
+       dh_testroot -a
+       dh_installdocs -a
+       dh_compress -a
+       dh_fixperms -a
+       dh_installdeb -a
+       dh_shlibdeps -a
+       dh_gencontrol -a
+       dh_md5sums -a
+       dh_builddeb -a
+
+binary: binary-indep binary-arch
+
+.PHONY: clean install binary-indep binary-arch binary