chiark / gitweb /
Rename `timeout' to `mtimeout' to prevent conflict with GNU Coreutils.
[misc] / debian / control
index cf1f43b56f0132a237efd78ff94df27dc170a72f..359f211c503e7b473aaec4bfe7e8782c85a6cf42 100644 (file)
@@ -1,28 +1,54 @@
 Source: nsict-utils
 Section: utils
 Priority: extra
-Maintainer: Mark Wooding <mdw@nsict.org>
+Maintainer: Mark Wooding <mdw@distorted.org.uk>
+Build-Depends: tinycdb, cdbs, python, python-cdb,
+ catacomb-dev (>= 2.1.1), mlib-dev (>= 2.0.4), libspamc-dev, libcdb-dev
 Standards-Version: 3.1.1
 
 Package: nsict-utils
 Architecture: all
 Section: utils
-Depends: mdwopt-perl, nsict-cdb, locking, qmail-checkspam, nsict-mail,
- if-mtu, shadowfix, zz, gorp, splitconf, xtitle
+Depends:
+       mdwopt-perl,
+       nsict-cdb,
+       locking,
+       qmail-checkspam,
+       nsict-mail,
+       if-mtu,
+       shadowfix,
+       zz,
+       gorp,
+       mtimeout,
+       splitconf,
+       xtitle,
+       pause,
+       buf,
+       create,
+       inplace,
+       stamp,
+       space,
+       getpass
 Description: Dummy package for convenience.
 
 Package: mdwopt-perl
 Architecture: all
-Section: libs
+Section: perl
 Depends: perl5
 Description: Options parser library for perl.
 
 Package: nsict-cdb
 Architecture: any
 Section: utils
-Depends: ${shlibs:Depends}, perl5, libcdb-file-perl
+Depends: ${shlibs:Depends}, python (>= 2.4), python-cdb
 Description: Simple utilities for messing with CDB files.
 
+Package: mtimeout
+Architecture: any
+Section: utils
+Depends: ${shlibs:Depends}
+Description: Run a program for at most a given amount of time.
+
 Package: locking
 Architecture: any
 Section: utils
@@ -61,10 +87,10 @@ Description: Run a program, automatically decompressing its argument files.
 
 Package: xtitle
 Architecture: any
-Depends: ${shlibs:Depends}, bash (>= 2.0.0)
+Depends: ${shlibs:Depends}
 Recommends: x-terminal-emulator
 Section: utils
-Description: Bash builtin for messing with xterm title bars.
+Description: Simple program for messing with xterm (or compatible) title bars.
 
 Package: splitconf
 Architecture: all
@@ -77,3 +103,49 @@ Architecture: any
 Depends: ${shlibs:Depends}
 Section: utils
 Description: Print a random base64 string.
+
+Package: pause
+Architecture: any
+Depends: ${shlibs:Depends}
+Section: utils
+Description: Wait for a given time, or until a key is pressed.
+
+Package: buf
+Architecture: all
+Section: utils
+Description: Captures stdin in a temporary file and runs a command.
+
+Package: create
+Architecture: all
+Section: utils
+Description: Simple script encapsulating atomic file update.
+
+Package: inplace
+Architecture: all
+Section: utils
+Description: Update files in place safely.
+
+Package: stamp
+Architecture: any
+Section: utils
+Description: Like cat, but prefixing each line with a datestamp.
+
+Package: getpass
+Architecture: any
+Section: utils
+Description: Read a password without echoing; write it to stdout.
+
+Package: space
+Architecture: any
+Section: utils
+Description: Identify and fix problematic whitespace in text files.
+ The space program won't send you to the moon, but it will identify
+ and fix problems such as trailing whitespace and spaces before tabs.
+ It can safely update files in place, and could therefore be used as part
+ of a commit hook.
+
+Package: x86-model
+Architecture: i386
+Section: utils
+Description: Shows basic model information about x86 processors.
+ The cpuid program is probably better for most people.