chiark / gitweb /
struct/buf.c: Add functions for serializing and deserializing `kludge64'.
[mLib] / debian / changelog
index 3662e45aea5c8c9066163acd60aa3f16b83600f6..a2fc30aad2b8627c421d8e8455ff7e682639ee58 100644 (file)
@@ -1,3 +1,49 @@
+mlib (2.5.0) experimental; urgency=medium
+
+  * Fix internal Python build scripts to work with Python 3.
+  * Introduce wrapper macros around the <ctype.h> functions (to handle
+    negative character codes correctly), and the <string.h> comparison
+    functions `strcmp', `strncmp', and `memcmp'.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 08 May 2020 20:16:37 +0100
+
+mlib (2.4.2) experimental; urgency=medium
+
+  * mlib (buf): Handle 64-bit length prefixes correctly on 32-bit
+    platforms.  Previously, a huge length was reduced modulo 2^32 prior to
+    checking via an implicit conversion to `size_t'.
+  * mlib (bres-adns): Use correct array bound when reassembling `hostent'
+    structures to return.  Apparently this has never been correct.
+  * mlib-dev: Some formatting fixes in manpages.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 08 May 2020 13:43:00 +0100
+
+mlib (2.4.1) experimental; urgency=medium
+
+  * (internals): Delete `track', which stopped being built or distributed
+    in 2.2.0 and nobody noticed.
+  * mlib-dev: Add a `STATIC_ASSERT' macro, because we've wanted one for ages.
+  * debian: Ship a shared-library `symbols' file for more precise
+    dependencies.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 15:13:30 +0100
+
+mlib (2.4.0) experimental; urgency=medium
+
+  * mlib (crc32): Make table be read-only.
+  * mlib-dev (macros): Decorate attribute names with `__...__'.
+  * mlib-bin (crc-mktab, unihash-mkstatic): Add option for generating
+    `const' tables.
+  * Support building with Clang.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 21:37:47 +0100
+
+mlib (2.3.3.1) experimental; urgency=medium
+
+  * macros: Add missing fallback definition for `NORETURN'.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 09 Aug 2019 11:32:38 +0100
+
 mlib (2.3.3) experimental; urgency=medium
 
   * mlib2-adns: Make sure there's a `DT_NEEDED' entry for libadns.  I