chiark / gitweb /
Add global unihash table; use universal hashing instead of CRC.
[mLib] / debian / control
index e6a480f04ff0eea03e7c077053b44001cfecffd0..b691aad0479cba26ad45829a7dfee23de5bab934 100644 (file)
@@ -12,6 +12,7 @@ Conflicts: mlib2-adns
 Description: A library of miscellaneous stuff
  The mLib library provides various handy utilities, including
    * yet another options parser, like GNU getopt but more so;
 Description: A library of miscellaneous stuff
  The mLib library provides various handy utilities, including
    * yet another options parser, like GNU getopt but more so;
+   * a simple but efficient universal hashing family;
    * a suite for writing event-driven select-based servers;
    * a simple exception-handling system, based on longjmp;
    * dynamically resizing strings and arrays;
    * a suite for writing event-driven select-based servers;
    * a simple exception-handling system, based on longjmp;
    * dynamically resizing strings and arrays;
@@ -31,6 +32,7 @@ Conflicts: mlib2
 Description: A library of miscellaneous stuff
  The mLib library provides various handy utilities, including
    * yet another options parser, like GNU getopt but more so;
 Description: A library of miscellaneous stuff
  The mLib library provides various handy utilities, including
    * yet another options parser, like GNU getopt but more so;
+   * a simple but efficient universal hashing family;
    * a suite for writing event-driven select-based servers;
    * a simple exception-handling system, based on longjmp;
    * dynamically resizing strings and arrays;
    * a suite for writing event-driven select-based servers;
    * a simple exception-handling system, based on longjmp;
    * dynamically resizing strings and arrays;
@@ -46,9 +48,11 @@ Package: mlib-dev
 Architecture: any
 Depends: mlib2 (= ${Source-Version}) | mlib2-adns (= ${Source-Version}),
  libc6-dev
 Architecture: any
 Depends: mlib2 (= ${Source-Version}) | mlib2-adns (= ${Source-Version}),
  libc6-dev
+Recommends: mlib-bin
 Description: A library of miscellaneous stuff
  The mLib library provides various handy utilities, including
    * yet another options parser, like GNU getopt but more so;
 Description: A library of miscellaneous stuff
  The mLib library provides various handy utilities, including
    * yet another options parser, like GNU getopt but more so;
+   * a simple but efficient universal hashing family;
    * a suite for writing event-driven select-based servers;
    * a simple exception-handling system, based on longjmp;
    * dynamically resizing strings and arrays;
    * a suite for writing event-driven select-based servers;
    * a simple exception-handling system, based on longjmp;
    * dynamically resizing strings and arrays;
@@ -57,3 +61,20 @@ Description: A library of miscellaneous stuff
    * a simple background DNS resolver.
  This package contains the header files and static libraries needed to
  compile programs which use mLib.
    * a simple background DNS resolver.
  This package contains the header files and static libraries needed to
  compile programs which use mLib.
+
+Package: mlib-bin
+Architecture: any
+Depends: ${shlibs:Depends}
+Recommends: mlib-dev
+Description: A library of miscellaneous stuff
+ The mLib library provides various handy utilities, including
+   * yet another options parser, like GNU getopt but more so;
+   * a simple but efficient universal hashing family;
+   * a suite for writing event-driven select-based servers;
+   * a simple exception-handling system, based on longjmp;
+   * dynamically resizing strings and arrays;
+   * a resizing hashtable;
+   * base64 and hex encoding and decoding; and
+   * a simple background DNS resolver.
+ This package contains some utility programs: in particular, to generate
+ static tables for efficient CRC and universal hashing computations.