chiark / gitweb /
struct/buf.c: Add functions for serializing and deserializing `kludge64'.
[mLib] / debian / control
index e6a480f04ff0eea03e7c077053b44001cfecffd0..54a897686ed0e97a4c124147d112a1d90874bcaf 100644 (file)
@@ -1,17 +1,20 @@
 Source: mlib
 Section: libs
 Priority: extra
-Maintainer: Mark Wooding <mdw@nsict.org>
-Build-Depends: debhelper (>= 4.0.2), libadns1-dev
+Maintainer: Mark Wooding <mdw@distorted.org.uk>
+Build-Depends: debhelper (>= 10), python, libadns1-dev
 Standards-Version: 3.1.1
 
 Package: mlib2
 Architecture: any
+Multi-Arch: same
 Depends: ${shlibs:Depends}
+Pre-Depends: ${misc:Pre-Depends}
 Conflicts: mlib2-adns
 Description: A library of miscellaneous stuff
  The mLib library provides various handy utilities, including
    * yet another options parser, like GNU getopt but more so;
+   * a simple but efficient universal hashing family;
    * a suite for writing event-driven select-based servers;
    * a simple exception-handling system, based on longjmp;
    * dynamically resizing strings and arrays;
@@ -21,16 +24,18 @@ Description: A library of miscellaneous stuff
  This package provides the mLib run-time library.  It uses an
  implementation of the background resolver forks and calls
  gethostbyname, so it therefore (a) depends only on the standard
- C library, and (b) is distributed under the terms of the GNU 
+ C library, and (b) is distributed under the terms of the GNU
  LGPL or GPL.
 
 Package: mlib2-adns
 Architecture: any
+Multi-Arch: same
 Depends: ${shlibs:Depends}
 Conflicts: mlib2
 Description: A library of miscellaneous stuff
  The mLib library provides various handy utilities, including
    * yet another options parser, like GNU getopt but more so;
+   * a simple but efficient universal hashing family;
    * a suite for writing event-driven select-based servers;
    * a simple exception-handling system, based on longjmp;
    * dynamically resizing strings and arrays;
@@ -44,11 +49,14 @@ Description: A library of miscellaneous stuff
 
 Package: mlib-dev
 Architecture: any
-Depends: mlib2 (= ${Source-Version}) | mlib2-adns (= ${Source-Version}),
+Depends: mlib2 (= ${binary:Version}) | mlib2-adns (= ${binary:Version}),
  libc6-dev
+Recommends: mlib-bin
+Section: devel
 Description: A library of miscellaneous stuff
  The mLib library provides various handy utilities, including
    * yet another options parser, like GNU getopt but more so;
+   * a simple but efficient universal hashing family;
    * a suite for writing event-driven select-based servers;
    * a simple exception-handling system, based on longjmp;
    * dynamically resizing strings and arrays;
@@ -57,3 +65,21 @@ Description: A library of miscellaneous stuff
    * a simple background DNS resolver.
  This package contains the header files and static libraries needed to
  compile programs which use mLib.
+
+Package: mlib-bin
+Architecture: any
+Depends: ${shlibs:Depends}
+Recommends: mlib-dev
+Section: utils
+Description: A library of miscellaneous stuff
+ The mLib library provides various handy utilities, including
+   * yet another options parser, like GNU getopt but more so;
+   * a simple but efficient universal hashing family;
+   * a suite for writing event-driven select-based servers;
+   * a simple exception-handling system, based on longjmp;
+   * dynamically resizing strings and arrays;
+   * a resizing hashtable;
+   * base64 and hex encoding and decoding; and
+   * a simple background DNS resolver.
+ This package contains some utility programs: in particular, to generate
+ static tables for efficient CRC and universal hashing computations.