chiark / gitweb /
Mention libsamplerate in readmes
authorRichard Kettlewell <rjk@greenend.org.uk>
Fri, 20 Nov 2009 18:52:15 +0000 (18:52 +0000)
committerRichard Kettlewell <rjk@greenend.org.uk>
Fri, 20 Nov 2009 18:52:15 +0000 (18:52 +0000)
CHANGES.html
README
README.developers

index 785f699..851fa34 100644 (file)
@@ -79,7 +79,11 @@ span.command {
       
       <p>The <tt>command</tt> backend now (optionally) sends silence instead
       of suspending writes when a pause occurs or no track is playing.</p>
-      
+
+      <p>If <a href="http://www.mega-nerd.com/SRC/">libsamplerate</a> is
+      available at build time then that will be used instead of invoking
+      <a href="http://sox.sourceforge.net/">SoX</>.  </p>
+
     </div>
       
     <h3>Disobedience</h3>
diff --git a/README b/README
index 64b0320..57435a8 100644 (file)
--- a/README
+++ b/README
@@ -34,6 +34,7 @@ Build dependencies:
   libao            0.8.6
   libasound        1.0.13
   libFLAC          1.1.2
+  libsamplerate    0.1.4       currently optional
   GNU C            4.1.2       }
   GNU Make         3.81        } Non-GNU versions will NOT work
   GNU Sed          4.1.5       }
index ed09c21..84b8129 100644 (file)
@@ -12,7 +12,7 @@ Dependencies:
      apt-get install gcc libc-dev automake autoconf libtool libgtk2.0-dev \
                     libgc-dev libgcrypt-dev libpcre3-dev libvorbis-dev \
                     libao-dev libmad0-dev libasound2-dev libdb4.3-dev \
-                    libflac-dev vorbis-tools wget
+                    libflac-dev vorbis-tools wget libsamplerate0-dev
 
      On lenny use libdb4.5-deb.  libdb4.6 does not work (and configure will
      refuse to use it).