chiark / gitweb /
README, debian/control: Deprecate `sox' support.
authorMark Wooding <mdw@distorted.org.uk>
Wed, 22 Nov 2017 23:03:34 +0000 (23:03 +0000)
committerMark Wooding <mdw@distorted.org.uk>
Sun, 26 Nov 2017 14:07:07 +0000 (14:07 +0000)
sox introduced yet more command-line options in 14.2, whinges about the
old ones in 14.4, and threatens to remove them in 14.5 (because
obviously compatibility between minor versions is an old-fashioned idea
whose day is long past).

Rather than chase this obnoxiously moving target,

  (a) report that sox support is deprecated and will be removed in some
      future major version of DisOrder; and

  (b) have the Debian package Build-Depend on `libsamplerate0-dev' so
      that at least Debian users don't have to put up with sox's moaning
      in the logs.

Reported-by: Ross Younger
README
debian/control

diff --git a/README b/README
index a8f88c2..92a3774 100644 (file)
--- a/README
+++ b/README
@@ -33,7 +33,7 @@ Build dependencies:
   libgcrypt        1.4.1
   libasound        1.0.16
   libFLAC          1.2.1
-  libsamplerate    0.1.4       currently optional
+  libsamplerate    0.1.4       currently optional but strongly recommended
   GStreamer        0.10        currently optional
   GNU C            4.2.1       }
   GNU Make         3.81        } Non-GNU versions will NOT work
@@ -45,6 +45,15 @@ Build dependencies:
 "Tested" means I've built against that version; earlier or later versions will
 often work too.
 
+If you don't have libsamplerate then DisOrder will try to run sox(1) to do
+sample-rate and channel conversion.  Unfortunately, sox has a tendency to
+change its command-line options incompatibly every few years.  Rather than
+chase this moving target by supporting the new options introduced in 14.2,
+I'm declaring DisOrder's sox support to be deprecated -- though (unlike
+sox's policy) it won't actually go away until the next major version.
+Alternatives include building against libsamplerate, or using GStreamer's
+audio decoding instead of DisOrder's built-in decoders.
+
 For the web interface to work you will additionally need a web server.  I've
 had both Apache 1.3.x and 2.x working.  Anything that supports CGI should be
 OK.
index 6a8967b..13ec3fb 100644 (file)
@@ -3,8 +3,8 @@ Maintainer: Richard Kettlewell <rjk@greenend.org.uk>
 Section: sound
 Priority: optional
 Standards-Version: 3.8.1.0
-Build-Depends: libgc6-dev | libgc-dev, libgcrypt-dev, libdb4.3-dev | libdb4.5-dev | libdb4.7-dev | libdb4.8-dev | libdb5.1-dev, libpcre3-dev, libvorbis-dev, libmad0-dev, libasound2-dev, libpulse-dev, python, libflac-dev, libgtk2.0-dev (>= 2.12.12), pkg-config, libgstreamer0.10-dev, libgstreamer-plugins-base0.10-dev
-Vcs-Git: https://github.com/ewxrjk/disorder.git
+Build-Depends: libgc6-dev | libgc-dev, libgcrypt-dev, libdb4.3-dev | libdb4.5-dev | libdb4.7-dev | libdb4.8-dev | libdb5.1-dev, libpcre3-dev, libvorbis-dev, libmad0-dev, libasound2-dev, libpulse-dev, python, libflac-dev, libgtk2.0-dev (>= 2.12.12), pkg-config, libgstreamer0.10-dev, libgstreamer-plugins-base0.10-dev, libsamplerate0-dev
+Vcs-Git: https://code.google.com/p/disorder/
 Homepage: http://www.greenend.org.uk/rjk/disorder/
 
 Package: disorder