chiark / gitweb /
latest compiler support policy
authorRichard Kettlewell <rjk@greenend.org.uk>
Sat, 28 Jun 2008 10:25:12 +0000 (11:25 +0100)
committerRichard Kettlewell <rjk@greenend.org.uk>
Sat, 28 Jun 2008 10:25:12 +0000 (11:25 +0100)
README.developers

index e104598..d0c1cdc 100644 (file)
@@ -187,10 +187,9 @@ Code And Patches:
      (But if your new feature only makes sense on a given platform then
      obviously its new dependencies don't need to be available elsewhere.)
 
-   * GCCisms such as typeof are used; the configure script asks for -std=gnu99
-     by default.  At least one active user is still using GCC 2.95, so
-     extensions that only appear in later versions are to be avoided for the
-     time being.
+   * GCCisms such as typeof and C99isms such as mixed declarations and named
+     structure initializers are used; the configure script asks for -std=gnu99
+     by default.  Some supported platforms are still on GCC 4.0.
 
    * Please submit patches either using 'diff -u', or by publishing a bzr
      branch somewhere I can get at it.