chiark / gitweb /
Partial untested FreeBSD and Linux support for scripts/setup.
[disorder] / debian / rules
index e9f8d9f10d53faa6d2f79ac3d152820d37abe07e..551014d91be72ac7f897a469dca06a4a3aea6ac3 100755 (executable)
@@ -1,6 +1,6 @@
 #! /usr/bin/make -f
 #
-# Copyright (C) 2004, 2005, 2006, 2007 Richard Kettlewell
+# Copyright (C) 2004-2008 Richard Kettlewell
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -53,9 +53,10 @@ FAKEROOT=fakeroot
 # run if building from a checkout rather than a tarball.
 build:
        @if test ! -f configure; then \
-         echo ./prepare ${CONFIGURE} ${CONFIGURE_EXTRA};\
-         ./prepare ${CONFIGURE} ${CONFIGURE_EXTRA};\
-       elif test ! -f config.status; then \
+         echo ./prepare;\
+         ./prepare;\
+       fi
+       @if test ! -f config.status; then \
          echo ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
          ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
        else\
@@ -104,9 +105,9 @@ pkg-disorder: build
        $(INSTALL_DATA) CHANGES README debian/README.Debian \
                BUGS README.* \
                debian/disorder/usr/share/doc/disorder/.
-       bzr log > debian/disorder/usr/share/doc/disorder/changelog
-       gzip -9f debian/disorder/usr/share/doc/disorder/changelog \
-                debian/disorder/usr/share/doc/disorder/CHANGES \
+       rm -f debian/disorder/usr/share/doc/disorder/README.mac
+       rm -f debian/disorder/usr/share/doc/disorder/README.freebsd
+       gzip -9f debian/disorder/usr/share/doc/disorder/CHANGES \
                 debian/disorder/usr/share/doc/disorder/README \
                 debian/disorder/usr/share/doc/disorder/README.* \
                 debian/disorder/usr/share/doc/disorder/BUGS \
@@ -156,8 +157,10 @@ pkg-disorder-server: build
                debian/disorder-server/etc/init.d/disorder
        $(INSTALL_DATA) debian/etc.disorder.config \
                debian/disorder-server/etc/disorder/config
-       $(INSTALL_DATA) debian/etc.disorder.options \
+       $(INSTALL_DATA) templates/options \
                debian/disorder-server/etc/disorder/options
+       $(INSTALL_DATA) debian/etc.disorder.options.user \
+               debian/disorder-server/etc/disorder/options.user
        $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) server/disorder.cgi \
                $(shell pwd)/debian/disorder-server/usr/lib/cgi-bin/disorder
        dpkg-shlibdeps -Tdebian/substvars.disorder-server \