chiark / gitweb /
When shutting down, kill -rescan and wait for it to finish. If -rescan outlives
[disorder] / debian / rules
index e9f8d9f10d53faa6d2f79ac3d152820d37abe07e..44219c5664913df8e1b53f9cac6adedd21555704 100755 (executable)
@@ -1,6 +1,6 @@
 #! /usr/bin/make -f
 #
-# Copyright (C) 2004, 2005, 2006, 2007 Richard Kettlewell
+# Copyright (C) 2004-2008 Richard Kettlewell
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -104,6 +104,8 @@ pkg-disorder: build
        $(INSTALL_DATA) CHANGES README debian/README.Debian \
                BUGS README.* \
                debian/disorder/usr/share/doc/disorder/.
+       rm -f debian/disorder/usr/share/doc/disorder/README.mac
+       rm -f debian/disorder/usr/share/doc/disorder/README.freebsd
        bzr log > debian/disorder/usr/share/doc/disorder/changelog
        gzip -9f debian/disorder/usr/share/doc/disorder/changelog \
                 debian/disorder/usr/share/doc/disorder/CHANGES \
@@ -156,8 +158,10 @@ pkg-disorder-server: build
                debian/disorder-server/etc/init.d/disorder
        $(INSTALL_DATA) debian/etc.disorder.config \
                debian/disorder-server/etc/disorder/config
-       $(INSTALL_DATA) debian/etc.disorder.options \
+       $(INSTALL_DATA) templates/options \
                debian/disorder-server/etc/disorder/options
+       $(INSTALL_DATA) debian/etc.disorder.options.user \
+               debian/disorder-server/etc/disorder/options.user
        $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) server/disorder.cgi \
                $(shell pwd)/debian/disorder-server/usr/lib/cgi-bin/disorder
        dpkg-shlibdeps -Tdebian/substvars.disorder-server \