chiark / gitweb /
CHANGES -> CHANGES.html in debian scripts too
[disorder] / debian / rules
index 4fa3d4c9f08729c94abfe34ff38c1083a6757be2..424f5065eb294222f74259afd5ce270f04beffdd 100755 (executable)
@@ -45,6 +45,10 @@ export INSTALL_DATA
 export INSTALL_SCRIPT
 export INSTALL_PROGRAM
 
+# We override sendmail to the value defined in policy, in case configure picks
+# up some other sendmail.
+SENDMAIL=/usr/sbin/sendmail
+
 LIBTOOL=./libtool
 FAKEROOT=fakeroot
 
@@ -62,7 +66,7 @@ build:
          echo ./config.status;\
          ./config.status;\
        fi
-       $(MAKE)
+       $(MAKE) SENDMAIL=${SENDMAIL}
 
 pkg-disorder: build
        rm -rf debian/disorder
@@ -190,9 +194,8 @@ pkg-disorder-playrtp: build
                debian/disorder-playrtp/usr/bin/*
        $(INSTALL_DATA) debian/README.RTP \
                debian/disorder-playrtp/usr/share/doc/disorder-playrtp/README
-       $(INSTALL_DATA) CHANGES debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES
-       gzip -9f debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES \
-                debian/disorder-playrtp/usr/share/man/man*/*
+       $(INSTALL_DATA) CHANGES.html debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES.html
+       gzip -9f debian/disorder-playrtp/usr/share/man/man*/*
        dpkg-gencontrol -isp -pdisorder-playrtp -Pdebian/disorder-playrtp -Tdebian/substvars.disorder-playrtp
        chown -R root:root debian/disorder-playrtp
        chmod -R g-ws debian/disorder-playrtp