chiark / gitweb /
Switch to GPL v3
[disorder] / debian / rules
index 20c38ca2f8c21e5e6de1742fe33de05fcb53dea0..86d835a413b69f0903bb029063ff4f0740705ce8 100755 (executable)
@@ -2,24 +2,26 @@
 #
 # Copyright (C) 2004-2008 Richard Kettlewell
 #
-# This program is free software; you can redistribute it and/or modify
+# This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
+# the Free Software Foundation, either version 3 of the License, or
 # (at your option) any later version.
 #
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-# General Public License for more details.
-#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
 # You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
-# USA
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
 #
 
+cgiexecdir=/usr/lib/cgi-bin
+httpdir=/var/www
+browser=x-www-browser
+
 # Options to configure.  This can be overridden by the caller if necessary.
-CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man --with-browser=x-www-browser
+CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man --with-browser=${browser} cgiexecdir="${cgiexecdir}" httpdir="${httpdir}"
 
 # Set DEB_BUILD_OPTIONS=noopt to produce a non-optimized build.
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -45,6 +47,10 @@ export INSTALL_DATA
 export INSTALL_SCRIPT
 export INSTALL_PROGRAM
 
+# We override sendmail to the value defined in policy, in case configure picks
+# up some other sendmail.
+SENDMAIL=/usr/sbin/sendmail
+
 LIBTOOL=./libtool
 FAKEROOT=fakeroot
 
@@ -62,7 +68,7 @@ build:
          echo ./config.status;\
          ./config.status;\
        fi
-       $(MAKE)
+       $(MAKE) SENDMAIL=${SENDMAIL}
 
 pkg-disorder: build
        rm -rf debian/disorder
@@ -100,11 +106,10 @@ pkg-disorder: build
        $(MKDIR) debian/disorder/etc/disorder
        dpkg-shlibdeps -Tdebian/substvars.disorder \
                debian/disorder/usr/bin/*
-       $(INSTALL_DATA) CHANGES README debian/README.Debian \
+       $(INSTALL_DATA) CHANGES.html README debian/README.Debian \
                BUGS README.* \
                debian/disorder/usr/share/doc/disorder/.
-       gzip -9f debian/disorder/usr/share/doc/disorder/CHANGES \
-                debian/disorder/usr/share/doc/disorder/README \
+       gzip -9f debian/disorder/usr/share/doc/disorder/README \
                 debian/disorder/usr/share/doc/disorder/README.* \
                 debian/disorder/usr/share/doc/disorder/BUGS \
                 debian/disorder/usr/share/man/man*/*
@@ -129,20 +134,20 @@ pkg-disorder-server: build
            $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
          fi;\
        done
-       $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C images
-       $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C server
-       $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C templates
-       $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C driver
-       $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C plugins
-       $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C sounds
-       $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C doc
+       $(MAKE) DESTDIR=`pwd`/debian/disorder-server installdirs install -C images
+       $(MAKE) DESTDIR=`pwd`/debian/disorder-server installdirs install -C server
+       $(MAKE) DESTDIR=`pwd`/debian/disorder-server installdirs install -C templates
+       $(MAKE) DESTDIR=`pwd`/debian/disorder-server installdirs install -C driver
+       $(MAKE) DESTDIR=`pwd`/debian/disorder-server installdirs install -C plugins
+       $(MAKE) DESTDIR=`pwd`/debian/disorder-server installdirs install -C sounds
+       $(MAKE) DESTDIR=`pwd`/debian/disorder-server installdirs install -C doc
        rm -rf debian/disorder-server/usr/share/man/man1
        rm -rf debian/disorder-server/usr/share/man/man3
        rm -f debian/disorder-server/usr/share/man/man5/disorder_config.5
        rm -f debian/disorder-server/usr/share/man/man5/disorder_protocol.5
        $(MKDIR) debian/disorder-server/etc/disorder
        $(MKDIR) debian/disorder-server/etc/init.d
-       $(MKDIR) debian/disorder-server/usr/lib/cgi-bin
+       $(MKDIR) debian/disorder-server${cgiexecdir}
        $(MKDIR) debian/disorder-server/var/lib/disorder
        $(INSTALL_SCRIPT) examples/disorder.init \
                debian/disorder-server/etc/init.d/disorder
@@ -152,10 +157,10 @@ pkg-disorder-server: build
                debian/disorder-server/etc/disorder/options
        $(INSTALL_DATA) debian/etc.disorder.options.user \
                debian/disorder-server/etc/disorder/options.user
-       $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) server/disorder.cgi \
-               $(shell pwd)/debian/disorder-server/usr/lib/cgi-bin/disorder
+       $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) cgi/disorder \
+               $(shell pwd)/debian/disorder-server${cgiexecdir}/disorder
        dpkg-shlibdeps -Tdebian/substvars.disorder-server \
-               debian/disorder-server/usr/lib/cgi-bin/disorder \
+               debian/disorder-server${cgiexecdir}/disorder \
                debian/disorder-server/usr/sbin/* \
                debian/disorder-server/usr/lib/disorder/*.so*
        rm -rf debian/disorder-server/usr/share/doc/disorder-server
@@ -191,9 +196,8 @@ pkg-disorder-playrtp: build
                debian/disorder-playrtp/usr/bin/*
        $(INSTALL_DATA) debian/README.RTP \
                debian/disorder-playrtp/usr/share/doc/disorder-playrtp/README
-       $(INSTALL_DATA) CHANGES debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES
-       gzip -9f debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES \
-                debian/disorder-playrtp/usr/share/man/man*/*
+       $(INSTALL_DATA) CHANGES.html debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES.html
+       gzip -9f debian/disorder-playrtp/usr/share/man/man*/*
        dpkg-gencontrol -isp -pdisorder-playrtp -Pdebian/disorder-playrtp -Tdebian/substvars.disorder-playrtp
        chown -R root:root debian/disorder-playrtp
        chmod -R g-ws debian/disorder-playrtp