chiark / gitweb /
Intermediate debian version number for internal consumption.
[disorder] / debian / rules
index 44219c5664913df8e1b53f9cac6adedd21555704..53dc48610e37ac648038d62f423f25f51948b1b5 100755 (executable)
@@ -53,9 +53,10 @@ FAKEROOT=fakeroot
 # run if building from a checkout rather than a tarball.
 build:
        @if test ! -f configure; then \
-         echo ./prepare ${CONFIGURE} ${CONFIGURE_EXTRA};\
-         ./prepare ${CONFIGURE} ${CONFIGURE_EXTRA};\
-       elif test ! -f config.status; then \
+         echo ./prepare;\
+         ./prepare;\
+       fi
+       @if test ! -f config.status; then \
          echo ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
          ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
        else\
@@ -104,11 +105,7 @@ pkg-disorder: build
        $(INSTALL_DATA) CHANGES README debian/README.Debian \
                BUGS README.* \
                debian/disorder/usr/share/doc/disorder/.
-       rm -f debian/disorder/usr/share/doc/disorder/README.mac
-       rm -f debian/disorder/usr/share/doc/disorder/README.freebsd
-       bzr log > debian/disorder/usr/share/doc/disorder/changelog
-       gzip -9f debian/disorder/usr/share/doc/disorder/changelog \
-                debian/disorder/usr/share/doc/disorder/CHANGES \
+       gzip -9f debian/disorder/usr/share/doc/disorder/CHANGES \
                 debian/disorder/usr/share/doc/disorder/README \
                 debian/disorder/usr/share/doc/disorder/README.* \
                 debian/disorder/usr/share/doc/disorder/BUGS \