chiark / gitweb /
Merge branch 'mdw/gstdecode'
[disorder] / debian / rules
index 1861c139e96d8ed71d8d73679fb45e5b7812d8ee..def2d53e68c72b20561174d5374ad5d5299f8164 100755 (executable)
@@ -1,6 +1,6 @@
 #! /usr/bin/make -f
 #
-# Copyright (C) 2004-2008 Richard Kettlewell
+# Copyright (C) 2004-2008, 2015 Richard Kettlewell
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -20,17 +20,15 @@ cgiexecdir=/usr/lib/cgi-bin
 httpdir=/var/www
 browser=x-www-browser
 
+CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+export CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+
 # Options to configure.  This can be overridden by the caller if necessary.
 CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man --with-browser=${browser} cgiexecdir="${cgiexecdir}" httpdir="${httpdir}"
 
-# Set DEB_BUILD_OPTIONS=noopt to produce a non-optimized build.
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-CFLAGS=-O0 -g
-else
-CFLAGS=-O2 -g
-endif
-export CFLAGS
-
 # Install commands.  You wouldn't normally override these.
 INSTALL=install
 INSTALL_DATA=$(INSTALL) -p -o root -g root -m 644
@@ -69,13 +67,7 @@ build:
          echo ./autogen.sh;\
          ./autogen.sh;\
        fi
-       @set -e;if test ! -f config.status; then \
-         echo ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
-         ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
-       else\
-         echo ./config.status;\
-         ./config.status;\
-       fi
+       ./configure ${CONFIGURE} ${CONFIGURE_EXTRA}
        $(MAKE) SENDMAIL=${SENDMAIL} ${PARALLEL}
 
 pkg-disorder: build
@@ -83,12 +75,13 @@ pkg-disorder: build
        $(MKDIR) debian/disorder
        $(MKDIR) debian/disorder/DEBIAN
        $(MKDIR) debian/disorder/usr/share/doc/disorder
+       $(MKDIR) debian/disorder/usr/share/lintian/overrides
        $(MKDIR) debian/disorder/etc/bash_completion.d
        $(INSTALL_DATA) debian/copyright \
                debian/disorder/usr/share/doc/disorder/copyright
        $(INSTALL_DATA) debian/changelog \
                debian/disorder/usr/share/doc/disorder/changelog
-       gzip -9 debian/disorder/usr/share/doc/disorder/changelog*
+       gzip -9n debian/disorder/usr/share/doc/disorder/changelog*
        @for f in conffiles templates; do\
          if test -e debian/$$f.disorder; then\
            echo $(INSTALL_DATA) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
@@ -101,6 +94,8 @@ pkg-disorder: build
            $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
          fi;\
        done
+       $(INSTALL_DATA) debian/overrides.disorder \
+               debian/disorder/usr/share/lintian/overrides/disorder
        $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C doc
        $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C clients
        strip --remove-section=.comment debian/disorder/usr/bin/disorder
@@ -123,9 +118,9 @@ pkg-disorder: build
        dpkg-shlibdeps -Tdebian/substvars.disorder \
                debian/disorder/usr/bin/*
        $(INSTALL_DATA) CHANGES.html README debian/README.Debian \
-               BUGS README.* \
+               BUGS README.* docs.css \
                debian/disorder/usr/share/doc/disorder/.
-       gzip -9f debian/disorder/usr/share/doc/disorder/README \
+       gzip -9nf debian/disorder/usr/share/doc/disorder/README \
                 debian/disorder/usr/share/doc/disorder/README.* \
                 debian/disorder/usr/share/doc/disorder/BUGS \
                 debian/disorder/usr/share/man/man*/*
@@ -150,7 +145,7 @@ pkg-disorder-server: build
                debian/disorder-server/usr/share/doc/disorder-server/copyright
        $(INSTALL_DATA) debian/changelog \
                debian/disorder-server/usr/share/doc/disorder-server/changelog
-       gzip -9 debian/disorder-server/usr/share/doc/disorder-server/changelog*
+       gzip -9n debian/disorder-server/usr/share/doc/disorder-server/changelog*
        @for f in preinst postinst prerm postrm config; do\
          if test -e debian/$$f.disorder-server; then\
            echo $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
@@ -174,6 +169,7 @@ pkg-disorder-server: build
        rm -f debian/disorder-server/usr/share/man/man5/disorder_config.5
        rm -f debian/disorder-server/usr/share/man/man5/disorder_preferences.5
        rm -f debian/disorder-server/usr/share/man/man5/disorder_protocol.5
+       rm -f debian/disorder-server/usr/sbin/disorder-gstdecode
        find debian/disorder-server -name '*.la' -print0 | xargs -r0 rm -f
        find debian/disorder-server -name '*.so.0' -print0 | xargs -r0 rm -f
        @for f in debian/disorder-server/usr/lib/disorder/*.so.0.0.0; do \
@@ -186,6 +182,7 @@ pkg-disorder-server: build
        $(MKDIR) debian/disorder-server/etc/init.d
        $(MKDIR) debian/disorder-server${cgiexecdir}
        $(MKDIR) debian/disorder-server/var/lib/disorder
+       $(MKDIR) debian/disorder-server/etc/cron.daily
        $(INSTALL_SCRIPT) examples/disorder.init \
                debian/disorder-server/etc/init.d/disorder
        $(INSTALL_DATA) debian/etc.disorder.config \
@@ -194,9 +191,10 @@ pkg-disorder-server: build
                debian/disorder-server/etc/disorder/options
        $(INSTALL_DATA) debian/etc.disorder.options.user \
                debian/disorder-server/etc/disorder/options.user
+       $(INSTALL_SCRIPT) debian/disorder.daily debian/disorder-server/etc/cron.daily/disorder
        $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) cgi/disorder \
                $(shell pwd)/debian/disorder-server${cgiexecdir}/disorder
-       gzip -9f debian/disorder-server/usr/share/man/man*/*
+       gzip -9nf debian/disorder-server/usr/share/man/man*/*
        dpkg-shlibdeps -Tdebian/substvars.disorder-server \
                debian/disorder-server${cgiexecdir}/disorder \
                debian/disorder-server/usr/sbin/* \
@@ -221,17 +219,20 @@ pkg-disorder-playrtp: build
        $(MKDIR) debian/disorder-playrtp
        $(MKDIR) debian/disorder-playrtp/DEBIAN
        $(MKDIR) debian/disorder-playrtp/usr/share/doc/disorder-playrtp
+       $(MKDIR) debian/disorder-playrtp/usr/share/lintian/overrides
        $(INSTALL_DATA) debian/copyright \
                debian/disorder-playrtp/usr/share/doc/disorder-playrtp/copyright
        $(INSTALL_DATA) debian/changelog \
                debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog
-       gzip -9 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog*
+       gzip -9n debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog*
        @for f in preinst postinst prerm postrm conffiles templates config; do\
          if test -e debian/$$f.disorder-playrtp; then\
            echo $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
            $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
          fi;\
        done
+       $(INSTALL_DATA) debian/overrides.disorder-playrtp \
+               debian/disorder-playrtp/usr/share/lintian/overrides/disorder-playrtp
        $(MKDIR) debian/disorder-playrtp/usr/bin
        $(MKDIR) debian/disorder-playrtp/usr/share/man/man1
        $(INSTALL_PROGRAM) clients/disorder-playrtp \
@@ -244,7 +245,7 @@ pkg-disorder-playrtp: build
        $(INSTALL_DATA) debian/README.RTP \
                debian/disorder-playrtp/usr/share/doc/disorder-playrtp/README
        $(INSTALL_DATA) CHANGES.html debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES.html
-       gzip -9f debian/disorder-playrtp/usr/share/man/man*/*
+       gzip -9nf debian/disorder-playrtp/usr/share/man/man*/*
        cd debian/disorder-playrtp && \
                find -name DEBIAN -prune -o -type f -print \
                        | sed 's/^\.\///' \
@@ -254,6 +255,42 @@ pkg-disorder-playrtp: build
        chmod -R g-ws debian/disorder-playrtp
        dpkg --build debian/disorder-playrtp ..
 
+pkg-disorder-gstdecode: build
+       rm -rf debian/disorder-gstdecode
+       $(MKDIR) debian/disorder-gstdecode
+       $(MKDIR) debian/disorder-gstdecode/DEBIAN
+       $(MKDIR) debian/disorder-gstdecode/usr/share/doc/disorder-gstdecode
+       $(INSTALL_DATA) debian/copyright \
+               debian/disorder-gstdecode/usr/share/doc/disorder-gstdecode/copyright
+       $(INSTALL_DATA) debian/changelog \
+               debian/disorder-gstdecode/usr/share/doc/disorder-gstdecode/changelog
+       gzip -9 debian/disorder-gstdecode/usr/share/doc/disorder-gstdecode/changelog*
+       @for f in preinst postinst prerm postrm conffiles templates config; do\
+         if test -e debian/$$f.disorder-gstdecode; then\
+           echo $(INSTALL_SCRIPT) debian/$$f.disorder-gstdecode debian/disorder-gstdecode/DEBIAN/$$f; \
+           $(INSTALL_SCRIPT) debian/$$f.disorder-gstdecode debian/disorder-gstdecode/DEBIAN/$$f; \
+         fi;\
+       done
+       $(MKDIR) debian/disorder-gstdecode/usr/sbin
+       $(MKDIR) debian/disorder-gstdecode/usr/share/man/man8
+       $(INSTALL_PROGRAM) server/disorder-gstdecode \
+               debian/disorder-gstdecode/usr/sbin/disorder-gstdecode
+       strip --remove-section=.comment debian/disorder-gstdecode/usr/sbin/disorder-gstdecode
+       $(INSTALL_DATA) doc/disorder-gstdecode.8 \
+               debian/disorder-gstdecode/usr/share/man/man8/disorder-gstdecode.8
+       dpkg-shlibdeps -Tdebian/substvars.disorder-gstdecode \
+               debian/disorder-gstdecode/usr/sbin/*
+       $(INSTALL_DATA) CHANGES.html debian/disorder-gstdecode/usr/share/doc/disorder-gstdecode/CHANGES.html
+       gzip -9f debian/disorder-gstdecode/usr/share/man/man*/*
+       cd debian/disorder-gstdecode && \
+               find -name DEBIAN -prune -o -type f -print \
+                       | sed 's/^\.\///' \
+                       | xargs md5sum > DEBIAN/md5sums
+       dpkg-gencontrol -isp -pdisorder-gstdecode -Pdebian/disorder-gstdecode -Tdebian/substvars.disorder-gstdecode
+       chown -R root:root debian/disorder-gstdecode
+       chmod -R g-ws debian/disorder-gstdecode
+       dpkg --build debian/disorder-gstdecode ..
+
 pkg-disobedience: build
        rm -rf debian/disobedience
        $(MKDIR) debian/disobedience
@@ -263,7 +300,7 @@ pkg-disobedience: build
                debian/disobedience/usr/share/doc/disobedience/copyright
        $(INSTALL_DATA) debian/changelog \
                debian/disobedience/usr/share/doc/disobedience/changelog
-       gzip -9 debian/disobedience/usr/share/doc/disobedience/changelog*
+       gzip -9n debian/disobedience/usr/share/doc/disobedience/changelog*
        @for f in preinst postinst prerm postrm conffiles templates config; do\
          if test -e debian/$$f.disobedience; then\
            echo $(INSTALL_SCRIPT) debian/$$f.disobedience debian/disobedience/DEBIAN/$$f; \
@@ -286,7 +323,7 @@ pkg-disobedience: build
                debian/disobedience/usr/share/menu/disobedience
        $(INSTALL_DATA) debian/disobedience-manual \
                debian/disobedience/usr/share/doc-base/disobedience-manual
-       gzip -9f debian/disobedience/usr/share/man/man*/*
+       gzip -9nf debian/disobedience/usr/share/man/man*/*
        dpkg-shlibdeps -Tdebian/substvars.disobedience \
                debian/disobedience/usr/bin/*
        rm -rf debian/disobedience/usr/share/doc/disobedience
@@ -319,11 +356,11 @@ source-check: source
 
 binary: binary-arch binary-indep
 binary-arch: pkg-disorder pkg-disorder-server pkg-disorder-playrtp \
-            pkg-disobedience
+            pkg-disorder-gstdecode pkg-disobedience
 binary-indep: 
 
 clean:
-       test -f Makefile && $(MAKE) distclean
+       if test -f Makefile; then $(MAKE) distclean; fi
        rm -f config.cache
        rm -f debian/files
        rm -f debian/substvars.*