chiark / gitweb /
Macroize submit buttons so we can mess with them more easily
[disorder] / configure.ac
index c38990c..18380c0 100644 (file)
@@ -1,7 +1,8 @@
 # Process this file with autoconf to produce a configure script.
 #
 # This file is part of DisOrder.
-# Copyright (C) 2004, 2005, 2006, 2007 Richard Kettlewell
+# Copyright (C) 2004-2008 Richard Kettlewell
+# Portions copyright (C) 2007 Ross Younger
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -19,9 +20,9 @@
 # USA
 #
 
-AC_INIT([disorder], [1.5.99+], [richard+disorder@sfere.greenend.org.uk])
+AC_INIT([disorder], [3.0+], [richard+disorder@sfere.greenend.org.uk])
 AC_CONFIG_AUX_DIR([config.aux])
-AM_INIT_AUTOMAKE(disorder, [1.5.99+])
+AM_INIT_AUTOMAKE(disorder, [3.0+])
 AC_CONFIG_SRCDIR([server/disorderd.c])
 AM_CONFIG_HEADER([config.h])
 
@@ -31,6 +32,7 @@ AC_CANONICAL_HOST
 # What we want to build
 want_gtk=yes
 want_python=yes
+want_tests=yes
 
 # APIs we want
 want_alsa=yes
@@ -43,6 +45,7 @@ AC_SET_MAKE
 if test "x$GCC" = xyes; then
   gcc_werror=-Werror
 else
+  AC_MSG_ERROR([GNU C is required to build this program])
   gcc_werror=""
 fi
 
@@ -58,6 +61,10 @@ AC_ARG_WITH([coreaudio],
            [AS_HELP_STRING([--without-coreaudio],
                            [do not build with Core Audio support])],
            [want_coreaudio=$withval])
+AC_ARG_WITH([tests],
+           [AS_HELP_STRING([--without-tests],
+                           [do not build test suit])],
+           [want_tests=$withval])
 
 AC_MSG_CHECKING([for a known target platform])
 case "$host" in
@@ -80,6 +87,50 @@ case "$host" in
     COREAUDIO="-framework CoreAudio"
   fi
   browser=open
+  AC_MSG_CHECKING([Mac OS X target version])
+  # We honor MACOSX_DEPLOYMENT_TARGET in the environment, emulating gcc's
+  # behaviour.  But we provide a command line option to override it and
+  # we default to wide support instead of supporting only the build platform.
+  #
+  # Currently if you ask for 10.5 you will get a deprecation warning
+  # when building the CoreAudio support code.  For the time being the
+  # answer to this is "don't do that then".  If a good reason to ask
+  # for a 10.5 deployment target emerges then this will be fixed.
+  if test -z "$MACOSX_DEPLOYMENT_TARGET"; then
+    MACOSX_DEPLOYMENT_TARGET=10.0
+  fi
+  AC_ARG_WITH([deployment-target],
+              [AS_HELP_STRING([--with-deployment-target=TARGET],
+                              [set target OS X version])],
+              [MACOSX_DEPLOYMENT_TARGET=$withval])
+  # Convert to desired format
+  underscored=`echo $MACOSX_DEPLOYMENT_TARGET|sed 's/\./_/'`
+  minver="MAC_OS_X_VERSION_$underscored"
+  AC_MSG_RESULT([$minver])
+  AC_DEFINE_UNQUOTED([MAC_OS_X_VERSION_MIN_REQUIRED], [$minver],
+                     [define to minimum version of Mac OS X to support])
+  ;;
+*-freebsd* )
+  AC_MSG_RESULT([FreeBSD])
+  want_server=yes
+  # Ports install to /usr/local but the compiler stupidly doesn't look
+  # there by default
+  LDFLAGS="${LDFLAGS} -L/usr/local/lib"
+  CPPFLAGS="${CPPFLAGS} -isystem /usr/local/include"
+  # Look for a suitable version of libdb among the versions found in FreeBSD 7.0
+  AC_CACHE_CHECK([looking for a libdb install],[rjk_cv_libdb],[
+    rjk_cv_libdb="none"
+    for db in db43 db44 db45 db46; do
+      if test -e /usr/local/lib/$db; then
+        rjk_cv_libdb=$db
+        break
+      fi
+    done
+  ])
+  if test $rjk_cv_libdb != none; then
+    LDFLAGS="${LDFLAGS} -L/usr/local/lib/$rjk_cv_libdb"
+    CPPFLAGS="${CPPFLAGS} -isystem /usr/local/include/$rjk_cv_libdb"
+  fi
   ;;
 * )
   AC_MSG_RESULT([unknown, winging it])
@@ -95,7 +146,7 @@ AC_ARG_WITH([browser],
 
 AC_CACHE_CHECK([default HTML viewer],[rjk_cv_browser],[
   rjk_cv_browser=UNKNOWN
-  for candidate in x-www-browser firefox mozilla konqueror netscape; do
+  for candidate in x-www-browser sensible-browser firefox mozilla konqueror netscape; do
     if type $candidate >/dev/null 2>&1; then
       rjk_cv_browser="$candidate"
       break
@@ -120,10 +171,14 @@ AC_ARG_WITH([python],
                            [do not build Python support])],
            [want_python=$withval])
 
-subdirs="scripts lib clients doc examples debian"
+subdirs="scripts lib"
+if test $want_tests = yes; then
+  subdirs="${subdirs} libtests"
+fi
+subdirs="${subdirs} clients doc examples debian"
 
 if test $want_server = yes; then
-  subdirs="${subdirs} server plugins driver templates sounds images"
+  subdirs="${subdirs} server cgi plugins driver templates sounds images"
 fi
 if test $want_gtk = yes; then
   subdirs="${subdirs} disobedience"
@@ -131,7 +186,7 @@ if test $want_gtk = yes; then
     subdirs="${subdirs} images"
   fi
 fi
-if test $want_python = yes; then
+if test $want_tests = yes && test $want_python = yes; then
   AM_PATH_PYTHON([2.4])
   subdirs="${subdirs} python tests"
 fi
@@ -143,12 +198,31 @@ AC_DISABLE_STATIC
 
 AC_PROG_LIBTOOL
 
+AC_CACHE_CHECK([for GNU sed],[rjk_cv_gnused],[
+  rjk_cv_gnused="not found"
+  for candidate in sed gsed; do
+    if $candidate --version >/dev/null 2>&1; then
+      rjk_cv_gnused=$candidate 
+    fi
+  done
+])
+GNUSED="${GNUSED:-$rjk_cv_gnused}"
+if test "$GNUSED" = "not found"; then
+  AC_MSG_ERROR([GNU sed is required to build this program])
+fi
+AC_SUBST([GNUSED])
+
+AC_CHECK_PROGS([GROG],[grog])
+AM_CONDITIONAL([GROG],[test "x$GROG" != xnone])
+
 missing_libraries=""
 missing_headers=""
 missing_functions=""
 
 AC_DEFINE(_GNU_SOURCE, 1, [required for e.g. strsignal])
 
+AC_PATH_PROG([SENDMAIL],[sendmail],[none],[$PATH:/usr/sbin:/usr/lib])
+
 # Macs might have libraries under fink's root
 AC_PATH_PROG([FINK],[fink],[none],[$PATH:/sw/bin])
 if test "x$FINK" != xnone; then
@@ -204,6 +278,9 @@ if test $want_server = yes; then
               [AC_SUBST(LIBFLAC,[-lFLAC])],
               [missing_libraries="$missing_libraries libFLAC"])
 fi
+AC_CHECK_LIB([pthread], [pthread_create],
+             [AC_SUBST(LIBPTHREAD,[-lpthread])],
+            [missing_libraries="$missing_libraries libpthread"])
 
 if test $want_gtk = yes; then
   AM_PATH_GLIB_2_0([],[],[missing_libraries="$missing_libraries libglib"])
@@ -232,9 +309,6 @@ if test ! -z "$missing_libraries"; then
   AC_MSG_ERROR([missing libraries:$missing_libraries])
 fi
 
-# We require that libpcre support UTF-8
-RJK_REQUIRE_PCRE_UTF8([-lpcre])
-
 # Checks for header files.
 RJK_FIND_GC_H
 if test $want_oss = yes; then
@@ -267,6 +341,9 @@ if test ! -z "$missing_headers"; then
   AC_MSG_ERROR([missing headers:$missing_headers])
 fi
 
+# We require that libpcre support UTF-8
+RJK_REQUIRE_PCRE_UTF8([-lpcre])
+
 # Checks for typedefs, structures, and compiler characteristics.
 AC_C_CONST
 AC_TYPE_SIZE_T
@@ -354,7 +431,7 @@ if test $ac_cv_type_long_long = yes; then
     AC_DEFINE([DECLARES_ATOLL],[1],[define if <stdlib.h> declares atoll])
   fi
 fi
-AC_CHECK_FUNCS([ioctl nl_langinfo strsignal],[:],[
+AC_CHECK_FUNCS([ioctl nl_langinfo strsignal setenv unsetenv],[:],[
   missing_functions="$missing_functions $ac_func"
 ])
 # fsync will do if fdatasync not available
@@ -365,6 +442,10 @@ AC_CHECK_FUNCS([fdatasync],[:],[
 if test ! -z "$missing_functions"; then
   AC_MSG_ERROR([missing functions:$missing_functions])
 fi
+
+# Functions we can take or leave
+AC_CHECK_FUNCS([fls])
+
 if test $want_server = yes; then
   # <db.h> had better be version 3 or later
   AC_CACHE_CHECK([db.h version],[rjk_cv_db_version],[
@@ -376,7 +457,7 @@ if test $want_server = yes; then
                       #if DB_VERSION_MAJOR < 4
                       # error inadequate db version
                       #endif
-                      #if DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR < 2
+                      #if DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR <= 2
                       # error inadequate db version
                       #endif
                      ],
@@ -388,7 +469,34 @@ if test $want_server = yes; then
   fi
 fi
 
+AM_CONDITIONAL([SERVER], [test x$want_server = xyes])
+if test $want_gtk = yes; then
+  AC_DEFINE([WITH_GTK], [1], [define if using GTK+])
+fi
+
 if test "x$GCC" = xyes; then
+  # We need LLONG_MAX and annoyingly GCC doesn't always give it to us
+  # by default.
+  AC_CACHE_CHECK([what C version to ask for],[rjk_cv_cstd],[
+    AC_TRY_COMPILE([#include <limits.h>],[
+      long long n = LLONG_MAX;
+    ],[rjk_cv_cstd=default],[
+      old_CC="$CC"
+      CC="${CC} -std=gnu99"
+      AC_TRY_COMPILE([#include <limits.h>],[
+        long long n = LLONG_MAX;
+      ],[rjk_cv_cstd=gnu99],[rjk_cv_cstd=unknown])
+      CC="$old_CC"
+    ])
+  ])
+  case $rjk_cv_cstd in
+  default | unknown )
+    ;;
+  * )
+    CC="${CC} -std=${rjk_cv_cstd}"
+    ;;
+  esac
+
   # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29478
   AC_CACHE_CHECK([checking for GCC bug 29478],[rjk_cv_pr29478],[
     old_CC="$CC"
@@ -426,7 +534,12 @@ if test "x$GCC" = xyes; then
                    rjk_cv_werror, [
       save_CFLAGS="${CFLAGS}"
       CFLAGS="${CFLAGS} ${GTK_CFLAGS} -Werror"
-      AC_TRY_COMPILE([#include <gtk/gtk.h>],
+      AC_TRY_COMPILE([#if WITH_GTK
+ #include <gtk/gtk.h>
+#endif
+
+struct s { int a, b; };
+const struct s sv = { .a = 1 };],
                     [],
                     [rjk_cv_werror=yes],
                     [rjk_cv_werror=no])
@@ -477,20 +590,22 @@ AH_BOTTOM([#ifdef __GNUC__
 #endif])
 
 AC_CONFIG_FILES([Makefile
-                templates/Makefile
                 images/Makefile
                 scripts/Makefile
                 lib/Makefile
                 server/Makefile
+                cgi/Makefile
                 clients/Makefile
                 disobedience/Makefile
                 doc/Makefile
+                templates/Makefile
                 plugins/Makefile
                 driver/Makefile
                 debian/Makefile
                 sounds/Makefile
                 python/Makefile
                 examples/Makefile
+                libtests/Makefile
                 tests/Makefile])
 AC_OUTPUT