chiark / gitweb /
configure.ac, debian/rules: Use `sensible-browser' by default.
[disorder] / debian / rules
1 #! /usr/bin/make -f
2
3 DH_OPTIONS               = --parallel -Bdebian/build
4 export LC_ALL            = C.UTF-8
5
6 ###--------------------------------------------------------------------------
7 ### Configuration.
8
9 cgiexecdir               = /usr/lib/cgi-bin
10 httpdir                  = /var/www
11 browser                  = sensible-browser
12
13 override_dh_auto_configure:
14         [ -f configure ] || ./autogen.sh
15         dh_auto_configure -- \
16                 --libdir="/usr/lib" \
17                 --localstatedir="/var/lib" \
18                 --with-browser="$(browser)" \
19                 cgiexecdir="$(cgiexecdir)" \
20                 httpdir="$(httpdir)"
21
22 ###--------------------------------------------------------------------------
23 ### Building.
24
25 ## We override sendmail to the value defined in policy, in case configure
26 ## picks up some other sendmail.
27 SENDMAIL                 = /usr/sbin/sendmail
28
29 override-dh_auto_build:
30         dh_auto_build -- \
31                 SENDMAIL="$(SENDMAIL)"
32
33 ###--------------------------------------------------------------------------
34 ### Installation.
35
36 ## Arrange for some packages to have /usr/share/doc/PKG be a symlink to
37 ## `disorder'.  The others have proper docs directories, for now.
38 DOCLINK_PKGS             = disorder-server disobedience
39 override_dh_installdocs:
40         dh_installdocs $(addprefix -p, $(DOCLINK_PKGS)) --link-doc=disorder
41         dh_installdocs $(addprefix -N, $(DOCLINK_PKGS))
42
43 ###--------------------------------------------------------------------------
44 ### Set up the proper dependencies for `disorder-gstreamer'.
45
46 override_dh_gencontrol:
47         dh_gencontrol -- -Tdebian/build/debian/substvars.auto
48
49 ###--------------------------------------------------------------------------
50 ### And just let Debhelper do the rest of the work.
51
52 %:; dh $@ $(DH_OPTIONS)