chiark / gitweb /
Sort out static content. There is a new expansion @image:NAME@ which
[disorder] / debian / rules
1 #! /usr/bin/make -f
2 #
3 # Copyright (C) 2004-2008 Richard Kettlewell
4 #
5 # This program is free software; you can redistribute it and/or modify
6 # it under the terms of the GNU General Public License as published by
7 # the Free Software Foundation; either version 2 of the License, or
8 # (at your option) any later version.
9 #
10 # This program is distributed in the hope that it will be useful, but
11 # WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
13 # General Public License for more details.
14 #
15 # You should have received a copy of the GNU General Public License
16 # along with this program; if not, write to the Free Software
17 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
18 # USA
19 #
20
21 # Options to configure.  This can be overridden by the caller if necessary.
22 CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man --with-browser=x-www-browser
23
24 # Set DEB_BUILD_OPTIONS=noopt to produce a non-optimized build.
25 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
26 CFLAGS=-O0 -g
27 else
28 CFLAGS=-O2 -g
29 endif
30 export CFLAGS
31
32 # Install commands.  You wouldn't normally override these.
33 INSTALL=install
34 INSTALL_DATA=$(INSTALL) -p -o root -g root -m 644
35 INSTALL_PROGRAM=$(INSTALL) -p -o root -g root -m 755
36 INSTALL_SCRIPT=$(INSTALL) -p -o root -g root -m 755
37 MKDIR=mkdir -p -m 755
38
39 # Set DEB_BUILD_OPTIONS=nostrip to install debuggable executables.
40 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
41 INSTALL_PROGRAM += -s
42 endif
43
44 export INSTALL_DATA
45 export INSTALL_SCRIPT
46 export INSTALL_PROGRAM
47
48 LIBTOOL=./libtool
49 FAKEROOT=fakeroot
50
51 .PHONY: build
52 # ./prepare is the script that generates configure etc.  It only needs to be
53 # run if building from a checkout rather than a tarball.
54 build:
55         @if test ! -f configure; then \
56           echo ./prepare ${CONFIGURE} ${CONFIGURE_EXTRA};\
57           ./prepare ${CONFIGURE} ${CONFIGURE_EXTRA};\
58         elif test ! -f config.status; then \
59           echo ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
60           ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
61         else\
62           echo ./config.status;\
63           ./config.status;\
64         fi
65         $(MAKE)
66
67 .PHONY: cleanpkg-disorder
68 cleanpkg-disorder:
69         rm -rf debian/disorder
70
71 .PHONY: pkg-disorder
72 pkg-disorder: build
73         rm -rf debian/disorder
74         $(MKDIR) debian/disorder
75         $(MKDIR) debian/disorder/DEBIAN
76         $(MKDIR) debian/disorder/usr/share/doc/disorder
77         $(MKDIR) debian/disorder/etc/bash_completion.d
78         $(INSTALL_DATA) debian/copyright \
79                 debian/disorder/usr/share/doc/disorder/copyright
80         $(INSTALL_DATA) debian/changelog \
81                 debian/disorder/usr/share/doc/disorder/changelog.Debian
82         gzip -9 debian/disorder/usr/share/doc/disorder/changelog.Debian
83         @for f in preinst postinst prerm postrm conffiles templates config; do\
84           if test -e debian/$$f.disorder; then\
85             echo $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
86             $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
87           fi;\
88         done
89         $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C doc
90         $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C clients
91         $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C lib
92         $(INSTALL_DATA) scripts/completion.bash \
93                 debian/disorder/etc/bash_completion.d/disorder
94         rm -rf debian/disorder/usr/share/man/man8
95         rm -rf debian/disorder/usr/share/disorder/*.html
96         rmdir debian/disorder/usr/share/disorder
97         rm -f debian/disorder/usr/bin/disorder-playrtp
98         rm -f debian/disorder/usr/bin/disobedience
99         rm -f debian/disorder/usr/share/man/man1/disorder-playrtp.1
100         rm -f debian/disorder/usr/share/man/man1/disobedience.1
101         $(MKDIR) debian/disorder/etc/disorder
102         dpkg-shlibdeps -Tdebian/substvars.disorder \
103                 debian/disorder/usr/bin/*
104         $(INSTALL_DATA) CHANGES README debian/README.Debian \
105                 BUGS README.* \
106                 debian/disorder/usr/share/doc/disorder/.
107         bzr log > debian/disorder/usr/share/doc/disorder/changelog
108         gzip -9f debian/disorder/usr/share/doc/disorder/changelog \
109                  debian/disorder/usr/share/doc/disorder/CHANGES \
110                  debian/disorder/usr/share/doc/disorder/README \
111                  debian/disorder/usr/share/doc/disorder/README.* \
112                  debian/disorder/usr/share/doc/disorder/BUGS \
113                  debian/disorder/usr/share/man/man*/*
114         dpkg-gencontrol -isp -pdisorder -Pdebian/disorder -Tdebian/substvars.disorder
115         chown -R root:root debian/disorder
116         chmod -R g-ws debian/disorder
117         dpkg --build debian/disorder ..
118
119
120 .PHONY: cleanpkg-disorder-server
121 cleanpkg-disorder-server:
122         rm -rf debian/disorder-server
123
124 .PHONY: pkg-disorder-server
125 pkg-disorder-server: build
126         rm -rf debian/disorder-server
127         $(MKDIR) debian/disorder-server
128         $(MKDIR) debian/disorder-server/DEBIAN
129         $(MKDIR) debian/disorder-server/usr/share/doc/disorder-server
130         $(INSTALL_DATA) debian/copyright \
131                 debian/disorder-server/usr/share/doc/disorder-server/copyright
132         $(INSTALL_DATA) debian/changelog \
133                 debian/disorder-server/usr/share/doc/disorder-server/changelog.Debian
134         gzip -9 debian/disorder-server/usr/share/doc/disorder-server/changelog.Debian
135         @for f in preinst postinst prerm postrm conffiles templates config; do\
136           if test -e debian/$$f.disorder-server; then\
137             echo $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
138             $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
139           fi;\
140         done
141         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C images
142         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C server
143         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C templates
144         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C driver
145         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C plugins
146         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C sounds
147         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C doc
148         rm -rf debian/disorder-server/usr/share/man/man1
149         rm -rf debian/disorder-server/usr/share/man/man3
150         rm -rf debian/disorder-server/usr/share/man/man5
151         $(MKDIR) debian/disorder-server/etc/disorder
152         $(MKDIR) debian/disorder-server/etc/init.d
153         $(MKDIR) debian/disorder-server/usr/lib/cgi-bin
154         $(MKDIR) debian/disorder-server/var/lib/disorder
155         $(INSTALL_SCRIPT) examples/disorder.init \
156                 debian/disorder-server/etc/init.d/disorder
157         $(INSTALL_DATA) debian/etc.disorder.config \
158                 debian/disorder-server/etc/disorder/config
159         $(INSTALL_DATA) templates/options \
160                 debian/disorder-server/etc/disorder/options
161         $(INSTALL_DATA) debian/etc.disorder.options.user \
162                 debian/disorder-server/etc/disorder/options.user
163         $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) server/disorder.cgi \
164                 $(shell pwd)/debian/disorder-server/usr/lib/cgi-bin/disorder
165         dpkg-shlibdeps -Tdebian/substvars.disorder-server \
166                 debian/disorder-server/usr/lib/cgi-bin/disorder \
167                 debian/disorder-server/usr/sbin/* \
168                 debian/disorder-server/usr/lib/disorder/*.so*
169         rm -rf debian/disorder-server/usr/share/doc/disorder-server
170         ln -s disorder debian/disorder-server/usr/share/doc/disorder-server
171         dpkg-gencontrol -isp -pdisorder-server -Pdebian/disorder-server -Tdebian/substvars.disorder-server
172         chown -R root:root debian/disorder-server
173         chmod -R g-ws debian/disorder-server
174         dpkg --build debian/disorder-server ..
175
176
177 .PHONY: cleanpkg-disorder-playrtp
178 cleanpkg-disorder-playrtp:
179         rm -rf debian/disorder-playrtp
180
181 .PHONY: pkg-disorder-playrtp
182 pkg-disorder-playrtp: build
183         rm -rf debian/disorder-playrtp
184         $(MKDIR) debian/disorder-playrtp
185         $(MKDIR) debian/disorder-playrtp/DEBIAN
186         $(MKDIR) debian/disorder-playrtp/usr/share/doc/disorder-playrtp
187         $(INSTALL_DATA) debian/copyright \
188                 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/copyright
189         $(INSTALL_DATA) debian/changelog \
190                 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog.Debian
191         gzip -9 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog.Debian
192         @for f in preinst postinst prerm postrm conffiles templates config; do\
193           if test -e debian/$$f.disorder-playrtp; then\
194             echo $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
195             $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
196           fi;\
197         done
198         $(MKDIR) debian/disorder-playrtp/usr/bin
199         $(MKDIR) debian/disorder-playrtp/usr/share/man/man1
200         $(INSTALL_PROGRAM) clients/disorder-playrtp \
201                 debian/disorder-playrtp/usr/bin/disorder-playrtp
202         $(INSTALL_DATA) doc/disorder-playrtp.1 \
203                 debian/disorder-playrtp/usr/share/man/man1/disorder-playrtp.1
204         dpkg-shlibdeps -Tdebian/substvars.disorder-playrtp \
205                 debian/disorder-playrtp/usr/bin/*
206         $(INSTALL_DATA) debian/README.RTP \
207                 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/README
208         $(INSTALL_DATA) CHANGES debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES
209         gzip -9f debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES \
210                  debian/disorder-playrtp/usr/share/man/man*/*
211         dpkg-gencontrol -isp -pdisorder-playrtp -Pdebian/disorder-playrtp -Tdebian/substvars.disorder-playrtp
212         chown -R root:root debian/disorder-playrtp
213         chmod -R g-ws debian/disorder-playrtp
214         dpkg --build debian/disorder-playrtp ..
215
216
217 .PHONY: cleanpkg-disobedience
218 cleanpkg-disobedience:
219         rm -rf debian/disobedience
220
221 .PHONY: pkg-disobedience
222 pkg-disobedience: build
223         rm -rf debian/disobedience
224         $(MKDIR) debian/disobedience
225         $(MKDIR) debian/disobedience/DEBIAN
226         $(MKDIR) debian/disobedience/usr/share/doc/disobedience
227         $(INSTALL_DATA) debian/copyright \
228                 debian/disobedience/usr/share/doc/disobedience/copyright
229         $(INSTALL_DATA) debian/changelog \
230                 debian/disobedience/usr/share/doc/disobedience/changelog.Debian
231         gzip -9 debian/disobedience/usr/share/doc/disobedience/changelog.Debian
232         @for f in preinst postinst prerm postrm conffiles templates config; do\
233           if test -e debian/$$f.disobedience; then\
234             echo $(INSTALL_SCRIPT) debian/$$f.disobedience debian/disobedience/DEBIAN/$$f; \
235             $(INSTALL_SCRIPT) debian/$$f.disobedience debian/disobedience/DEBIAN/$$f; \
236           fi;\
237         done
238         $(MKDIR) debian/disobedience/usr/bin
239         $(MKDIR) debian/disobedience/usr/share/man/man1
240         $(MKDIR) debian/disobedience/usr/share/pixmaps
241         $(MKDIR) debian/disobedience/usr/share/menu
242         $(MAKE) -C disobedience install DESTDIR=`pwd`/debian/disobedience
243         $(INSTALL_DATA) doc/disobedience.1 \
244                 debian/disobedience/usr/share/man/man1/disobedience.1
245         $(INSTALL_DATA) images/disobedience16x16.xpm \
246                         images/disobedience32x32.xpm \
247                         debian/disobedience/usr/share/pixmaps
248         $(INSTALL_DATA) debian/usr.share.menu.disobedience \
249                 debian/disobedience/usr/share/menu/disobedience
250         dpkg-shlibdeps -Tdebian/substvars.disobedience \
251                 debian/disobedience/usr/bin/*
252         rm -rf debian/disobedience/usr/share/doc/disobedience
253         ln -s disorder debian/disobedience/usr/share/doc/disobedience
254         dpkg-gencontrol -isp -pdisobedience -Pdebian/disobedience -Tdebian/substvars.disobedience
255         chown -R root:root debian/disobedience
256         chmod -R g-ws debian/disobedience
257         dpkg --build debian/disobedience ..
258
259
260 DEBVERSION:=$(shell dpkg-parsechangelog|awk '/Version:/ {print $$2}')
261 DSC=disorder_$(DEBVERSION).dsc
262 DEBSRC=disorder_$(DEBVERSION).tar.gz
263 VERSION=$(shell $(MAKE) echo-version)
264
265 source:
266         $(MAKE) dist
267         rm -rf disorder-$(VERSION)
268         tar xfz disorder-$(VERSION).tar.gz
269         dpkg-source -b disorder-$(VERSION)
270         rm -rf disorder-$(VERSION) disorder-$(VERSION).tar.gz
271
272 source-check: source
273         rm -rf disorder-$(DEBVERSION)
274         dpkg-source -x $(DSC)
275         cd disorder-$(DEBVERSION) && dpkg-buildpackage -r$(FAKEROOT)
276
277 .PHONY: source source-check
278
279 .PHONY: binary binary-arch binary-indep
280 binary: binary-arch binary-indep
281 binary-arch:  pkg-disorder pkg-disorder-server pkg-disorder-playrtp pkg-disobedience
282 binary-indep: 
283
284 .PHONY: clean
285 clean:  cleanpkg-disorder cleanpkg-disorder-server cleanpkg-disorder-playrtp cleanpkg-disobedience
286         -$(MAKE) distclean
287         rm -f config.cache
288         rm -f debian/files
289         rm -f debian/substvars.*