chiark / gitweb /
Remove arch tags throughout
[disorder] / debian / rules.m4
1 #
2 # This file is part of DisOrder.
3 # Copyright (C) 2004, 2005, 2006 Richard Kettlewell
4 #
5 # This program is free software; you can redistribute it and/or modify
6 # it under the terms of the GNU General Public License as published by
7 # the Free Software Foundation; either version 2 of the License, or
8 # (at your option) any later version.
9 #
10 # This program is distributed in the hope that it will be useful, but
11 # WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
13 # General Public License for more details.
14 #
15 # You should have received a copy of the GNU General Public License
16 # along with this program; if not, write to the Free Software
17 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
18 # USA
19 #
20
21 CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man
22 LIBTOOL=./libtool
23
24 build
25
26 archpkg([disorder], [   m4_dnl
27         $(MAKE) DESTDIR=`pwd`/debian/disorder staticdir=/var/www/disorder installdirs install
28         mkdir -m 755 -p debian/disorder/etc/disorder
29         mkdir -m 755 -p debian/disorder/etc/init.d
30         mkdir -m 755 -p debian/disorder/usr/lib/cgi-bin/disorder
31         mkdir -m 755 -p debian/disorder/var/lib/disorder
32         mkdir -m 755 -p debian/disorder/usr/share/doc/disorder/ChangeLog.d
33         $(INSTALL) -m 755 examples/disorder.init \
34                 debian/disorder/etc/init.d/disorder
35         $(INSTALL) -m 644 debian/disorder.config \
36                 debian/disorder/etc/disorder/config
37         $(INSTALL) -m 644 debian/options.debian \
38                 debian/disorder/etc/disorder/options
39         $(LIBTOOL) --mode=install $(INSTALL) -m 555 server/disorder.cgi \
40                 $(shell pwd)/debian/disorder/usr/lib/cgi-bin/disorder/disorder
41         dpkg-shlibdeps -Tdebian/substvars.disorder \
42                 debian/disorder/usr/bin/* \
43                 debian/disorder/usr/lib/cgi-bin/disorder/* \
44                 debian/disorder/usr/sbin/* \
45                 debian/disorder/usr/lib/*.so* \
46                 debian/disorder/usr/lib/disorder/*.so*
47         $(INSTALL) -m 444 debian/htaccess \
48                 debian/disorder/usr/lib/cgi-bin/disorder/.htaccess
49         $(INSTALL) -m 444 CHANGES README debian/README.Debian \
50                 BUGS README.* \
51                 debian/disorder/usr/share/doc/disorder/.
52         $(INSTALL) -m 444 ChangeLog.d/*--* \
53                 debian/disorder/usr/share/doc/disorder/ChangeLog.d
54         $(INSTALL) -m 444 COPYING debian/disorder/usr/share/doc/disorder/GPL
55         gzip -9f debian/disorder/usr/share/doc/disorder/ChangeLog.d/*--* \
56                  debian/disorder/usr/share/doc/disorder/CHANGES \
57                  debian/disorder/usr/share/doc/disorder/README \
58                  debian/disorder/usr/share/doc/disorder/README.* \
59                  debian/disorder/usr/share/doc/disorder/BUGS \
60                  debian/disorder/usr/share/doc/disorder/GPL
61         $(INSTALL) -m 555 debian/postinst debian/prerm debian/postrm \
62                 debian/config \
63                 debian/conffiles \
64                 debian/disorder/DEBIAN/.
65         $(INSTALL) -m 444 debian/templates debian/disorder/DEBIAN/.
66 ])
67
68 binary
69
70 clean
71
72 regenerate