chiark / gitweb /
Catch up with new CGI location
[disorder] / debian / rules
1 #! /usr/bin/make -f
2 #
3 # Copyright (C) 2004-2008 Richard Kettlewell
4 #
5 # This program is free software; you can redistribute it and/or modify
6 # it under the terms of the GNU General Public License as published by
7 # the Free Software Foundation; either version 2 of the License, or
8 # (at your option) any later version.
9 #
10 # This program is distributed in the hope that it will be useful, but
11 # WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
13 # General Public License for more details.
14 #
15 # You should have received a copy of the GNU General Public License
16 # along with this program; if not, write to the Free Software
17 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
18 # USA
19 #
20
21 # Options to configure.  This can be overridden by the caller if necessary.
22 CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man --with-browser=x-www-browser
23
24 # Set DEB_BUILD_OPTIONS=noopt to produce a non-optimized build.
25 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
26 CFLAGS=-O0 -g
27 else
28 CFLAGS=-O2 -g
29 endif
30 export CFLAGS
31
32 # Install commands.  You wouldn't normally override these.
33 INSTALL=install
34 INSTALL_DATA=$(INSTALL) -p -o root -g root -m 644
35 INSTALL_PROGRAM=$(INSTALL) -p -o root -g root -m 755
36 INSTALL_SCRIPT=$(INSTALL) -p -o root -g root -m 755
37 MKDIR=mkdir -p -m 755
38
39 # Set DEB_BUILD_OPTIONS=nostrip to install debuggable executables.
40 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
41 INSTALL_PROGRAM += -s
42 endif
43
44 export INSTALL_DATA
45 export INSTALL_SCRIPT
46 export INSTALL_PROGRAM
47
48 LIBTOOL=./libtool
49 FAKEROOT=fakeroot
50
51 # ./prepare is the script that generates configure etc.  It only needs to be
52 # run if building from a checkout rather than a tarball.
53 build:
54         @set -e;if test ! -f configure; then \
55           echo ./prepare;\
56           ./prepare;\
57         fi
58         @set -e;if test ! -f config.status; then \
59           echo ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
60           ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
61         else\
62           echo ./config.status;\
63           ./config.status;\
64         fi
65         $(MAKE)
66
67 pkg-disorder: build
68         rm -rf debian/disorder
69         $(MKDIR) debian/disorder
70         $(MKDIR) debian/disorder/DEBIAN
71         $(MKDIR) debian/disorder/usr/share/doc/disorder
72         $(MKDIR) debian/disorder/etc/bash_completion.d
73         $(INSTALL_DATA) debian/copyright \
74                 debian/disorder/usr/share/doc/disorder/copyright
75         $(INSTALL_DATA) debian/changelog \
76                 debian/disorder/usr/share/doc/disorder/changelog.Debian
77         gzip -9 debian/disorder/usr/share/doc/disorder/changelog.Debian
78         @for f in preinst postinst prerm postrm conffiles templates config; do\
79           if test -e debian/$$f.disorder; then\
80             echo $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
81             $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
82           fi;\
83         done
84         $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C doc
85         $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C clients
86         $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C lib
87         $(INSTALL_DATA) scripts/completion.bash \
88                 debian/disorder/etc/bash_completion.d/disorder
89         rm -rf debian/disorder/usr/share/man/man8
90         rm -rf debian/disorder/usr/share/disorder/*.html
91         rm -rf debian/disorder/usr/share/disorder/*.tmpl
92         rmdir debian/disorder/usr/share/disorder
93         rm -f debian/disorder/usr/bin/disorder-playrtp
94         rm -f debian/disorder/usr/bin/disobedience
95         rm -f debian/disorder/usr/share/man/man1/disorder-playrtp.1
96         rm -f debian/disorder/usr/share/man/man1/disobedience.1
97         rm -f debian/disorder/usr/share/man/man5/disorder_templates.5
98         rm -f debian/disorder/usr/share/man/man5/disorder_actions.5
99         rm -f debian/disorder/usr/share/man/man5/disorder_options.5
100         $(MKDIR) debian/disorder/etc/disorder
101         dpkg-shlibdeps -Tdebian/substvars.disorder \
102                 debian/disorder/usr/bin/*
103         $(INSTALL_DATA) CHANGES README debian/README.Debian \
104                 BUGS README.* \
105                 debian/disorder/usr/share/doc/disorder/.
106         gzip -9f debian/disorder/usr/share/doc/disorder/CHANGES \
107                  debian/disorder/usr/share/doc/disorder/README \
108                  debian/disorder/usr/share/doc/disorder/README.* \
109                  debian/disorder/usr/share/doc/disorder/BUGS \
110                  debian/disorder/usr/share/man/man*/*
111         dpkg-gencontrol -isp -pdisorder -Pdebian/disorder -Tdebian/substvars.disorder
112         chown -R root:root debian/disorder
113         chmod -R g-ws debian/disorder
114         dpkg --build debian/disorder ..
115
116 pkg-disorder-server: build
117         rm -rf debian/disorder-server
118         $(MKDIR) debian/disorder-server
119         $(MKDIR) debian/disorder-server/DEBIAN
120         $(MKDIR) debian/disorder-server/usr/share/doc/disorder-server
121         $(INSTALL_DATA) debian/copyright \
122                 debian/disorder-server/usr/share/doc/disorder-server/copyright
123         $(INSTALL_DATA) debian/changelog \
124                 debian/disorder-server/usr/share/doc/disorder-server/changelog.Debian
125         gzip -9 debian/disorder-server/usr/share/doc/disorder-server/changelog.Debian
126         @for f in preinst postinst prerm postrm conffiles templates config; do\
127           if test -e debian/$$f.disorder-server; then\
128             echo $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
129             $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
130           fi;\
131         done
132         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C images
133         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C server
134         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C templates
135         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C driver
136         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C plugins
137         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C sounds
138         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C doc
139         rm -rf debian/disorder-server/usr/share/man/man1
140         rm -rf debian/disorder-server/usr/share/man/man3
141         rm -f debian/disorder-server/usr/share/man/man5/disorder_config.5
142         rm -f debian/disorder-server/usr/share/man/man5/disorder_protocol.5
143         $(MKDIR) debian/disorder-server/etc/disorder
144         $(MKDIR) debian/disorder-server/etc/init.d
145         $(MKDIR) debian/disorder-server/usr/lib/cgi-bin
146         $(MKDIR) debian/disorder-server/var/lib/disorder
147         $(INSTALL_SCRIPT) examples/disorder.init \
148                 debian/disorder-server/etc/init.d/disorder
149         $(INSTALL_DATA) debian/etc.disorder.config \
150                 debian/disorder-server/etc/disorder/config
151         $(INSTALL_DATA) templates/options \
152                 debian/disorder-server/etc/disorder/options
153         $(INSTALL_DATA) debian/etc.disorder.options.user \
154                 debian/disorder-server/etc/disorder/options.user
155         $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) cgi/disorder.cgi \
156                 $(shell pwd)/debian/disorder-server/usr/lib/cgi-bin/disorder
157         dpkg-shlibdeps -Tdebian/substvars.disorder-server \
158                 debian/disorder-server/usr/lib/cgi-bin/disorder \
159                 debian/disorder-server/usr/sbin/* \
160                 debian/disorder-server/usr/lib/disorder/*.so*
161         rm -rf debian/disorder-server/usr/share/doc/disorder-server
162         ln -s disorder debian/disorder-server/usr/share/doc/disorder-server
163         dpkg-gencontrol -isp -pdisorder-server -Pdebian/disorder-server -Tdebian/substvars.disorder-server
164         chown -R root:root debian/disorder-server
165         chmod -R g-ws debian/disorder-server
166         dpkg --build debian/disorder-server ..
167
168 pkg-disorder-playrtp: build
169         rm -rf debian/disorder-playrtp
170         $(MKDIR) debian/disorder-playrtp
171         $(MKDIR) debian/disorder-playrtp/DEBIAN
172         $(MKDIR) debian/disorder-playrtp/usr/share/doc/disorder-playrtp
173         $(INSTALL_DATA) debian/copyright \
174                 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/copyright
175         $(INSTALL_DATA) debian/changelog \
176                 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog.Debian
177         gzip -9 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog.Debian
178         @for f in preinst postinst prerm postrm conffiles templates config; do\
179           if test -e debian/$$f.disorder-playrtp; then\
180             echo $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
181             $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
182           fi;\
183         done
184         $(MKDIR) debian/disorder-playrtp/usr/bin
185         $(MKDIR) debian/disorder-playrtp/usr/share/man/man1
186         $(INSTALL_PROGRAM) clients/disorder-playrtp \
187                 debian/disorder-playrtp/usr/bin/disorder-playrtp
188         $(INSTALL_DATA) doc/disorder-playrtp.1 \
189                 debian/disorder-playrtp/usr/share/man/man1/disorder-playrtp.1
190         dpkg-shlibdeps -Tdebian/substvars.disorder-playrtp \
191                 debian/disorder-playrtp/usr/bin/*
192         $(INSTALL_DATA) debian/README.RTP \
193                 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/README
194         $(INSTALL_DATA) CHANGES debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES
195         gzip -9f debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES \
196                  debian/disorder-playrtp/usr/share/man/man*/*
197         dpkg-gencontrol -isp -pdisorder-playrtp -Pdebian/disorder-playrtp -Tdebian/substvars.disorder-playrtp
198         chown -R root:root debian/disorder-playrtp
199         chmod -R g-ws debian/disorder-playrtp
200         dpkg --build debian/disorder-playrtp ..
201
202 pkg-disobedience: build
203         rm -rf debian/disobedience
204         $(MKDIR) debian/disobedience
205         $(MKDIR) debian/disobedience/DEBIAN
206         $(MKDIR) debian/disobedience/usr/share/doc/disobedience
207         $(INSTALL_DATA) debian/copyright \
208                 debian/disobedience/usr/share/doc/disobedience/copyright
209         $(INSTALL_DATA) debian/changelog \
210                 debian/disobedience/usr/share/doc/disobedience/changelog.Debian
211         gzip -9 debian/disobedience/usr/share/doc/disobedience/changelog.Debian
212         @for f in preinst postinst prerm postrm conffiles templates config; do\
213           if test -e debian/$$f.disobedience; then\
214             echo $(INSTALL_SCRIPT) debian/$$f.disobedience debian/disobedience/DEBIAN/$$f; \
215             $(INSTALL_SCRIPT) debian/$$f.disobedience debian/disobedience/DEBIAN/$$f; \
216           fi;\
217         done
218         $(MKDIR) debian/disobedience/usr/bin
219         $(MKDIR) debian/disobedience/usr/share/man/man1
220         $(MKDIR) debian/disobedience/usr/share/pixmaps
221         $(MKDIR) debian/disobedience/usr/share/menu
222         $(MAKE) -C disobedience install DESTDIR=`pwd`/debian/disobedience
223         $(INSTALL_DATA) doc/disobedience.1 \
224                 debian/disobedience/usr/share/man/man1/disobedience.1
225         $(INSTALL_DATA) images/disobedience16x16.xpm \
226                         images/disobedience32x32.xpm \
227                         debian/disobedience/usr/share/pixmaps
228         $(INSTALL_DATA) debian/usr.share.menu.disobedience \
229                 debian/disobedience/usr/share/menu/disobedience
230         dpkg-shlibdeps -Tdebian/substvars.disobedience \
231                 debian/disobedience/usr/bin/*
232         rm -rf debian/disobedience/usr/share/doc/disobedience
233         ln -s disorder debian/disobedience/usr/share/doc/disobedience
234         dpkg-gencontrol -isp -pdisobedience -Pdebian/disobedience -Tdebian/substvars.disobedience
235         chown -R root:root debian/disobedience
236         chmod -R g-ws debian/disobedience
237         dpkg --build debian/disobedience ..
238
239 DEBVERSION:=$(shell dpkg-parsechangelog|awk '/Version:/ {print $$2}')
240 DSC=disorder_$(DEBVERSION).dsc
241 DEBSRC=disorder_$(DEBVERSION).tar.gz
242 VERSION=$(shell $(MAKE) echo-version)
243
244 source:
245         $(MAKE) dist
246         rm -rf disorder-$(VERSION)
247         tar xfz disorder-$(VERSION).tar.gz
248         dpkg-source -b disorder-$(VERSION)
249         rm -rf disorder-$(VERSION) disorder-$(VERSION).tar.gz
250
251 source-check: source
252         rm -rf disorder-$(DEBVERSION)
253         dpkg-source -x $(DSC)
254         cd disorder-$(DEBVERSION) && dpkg-buildpackage -r$(FAKEROOT)
255
256 binary: binary-arch binary-indep
257 binary-arch: pkg-disorder pkg-disorder-server pkg-disorder-playrtp \
258              pkg-disobedience
259 binary-indep: 
260
261 clean:
262         -$(MAKE) distclean
263         rm -f config.cache
264         rm -f debian/files
265         rm -f debian/substvars.*
266         rm -rf debian/disorder
267         rm -rf debian/disorder-server
268         rm -rf debian/disorder-playrtp
269         rm -rf debian/disobedience
270
271 .PHONY: clean build pkg-disorder pkg-disorder-server pkg-disorder-playrtp \
272         pkg-disobedience source source-check binary binary-arch binary-indep