chiark / gitweb /
debian/: Ship correct symbols files.
[catacomb] / debian / rules
index 938998882163b5b0fc00a70d02eba0982df8f573..3fb55def1f1c20a62ffaa228e9a77a1fcf906a00 100755 (executable)
@@ -6,3 +6,7 @@ DH_OPTIONS = --parallel --without=autoreconf -Bdebian/build
 override_dh_auto_test:
        dh_auto_test $(addprefix -O, $(DH_OPTIONS))
        CATACOMB_CPUFEAT="-*" dh_auto_test $(addprefix -O, $(DH_OPTIONS))
+
+## Check that the shared-library symbols are plausible.
+override_dh_makeshlibs:
+       dh_makeshlibs -- -c4