chiark / gitweb /
debian/: Bump to Debhelper 10.
[catacomb] / debian / rules
index cec98bbefd3fecee9c600823051662e275a37f25..938998882163b5b0fc00a70d02eba0982df8f573 100755 (executable)
@@ -1,2 +1,8 @@
 #! /usr/bin/make -f
-%:; dh $@ --parallel -Bdebian/build
+DH_OPTIONS = --parallel --without=autoreconf -Bdebian/build
+%:; dh $@ $(DH_OPTIONS)
+
+## Test both with and without CPU-specific optimizations.
+override_dh_auto_test:
+       dh_auto_test $(addprefix -O, $(DH_OPTIONS))
+       CATACOMB_CPUFEAT="-*" dh_auto_test $(addprefix -O, $(DH_OPTIONS))