chiark / gitweb /
debian/: Use `dh_python2' for packaging.
[catacomb-python] / debian / changelog
index c7895ba435b146c21237a6d0e9adefa007f19e60..aaee0c3d0719136faab5bdf3eb87b4becc471092 100644 (file)
@@ -1,3 +1,41 @@
+catacomb-python (1.2.1) experimental; urgency=low
+
+  * Fix use-after-free bug in ECPt hashing causing hash instability.
+  * Fix keywrd argument mismatch in ECDSAPriv.
+  * Coerce DSA private key values to `MP'.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Fri, 16 Jun 2017 01:01:05 +0100
+
+catacomb-python (1.2.0) experimental; urgency=low
+
+  * Bindings for HSalsa20 and HChaCha PRFs.
+  * Bindings for Poly1305.
+  * Bindings for X25519.
+  * Bindings for X448.
+  * Bindings for Ed25519.
+  * Bindings for Ed448.
+  * Bindings for Keccak[1600, n].
+  * Bindings for cSHAKE; Python implementation of KMAC.
+  * Improved pretty-printing for IPython.
+  * Allow selection of public exponent when generating RSA keys.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 17:29:53 +0100
+
+catacomb-python (1.1.2) experimental; urgency=low
+
+  * Further 64-bit compatibility improvements.
+  * Fixed docstrings for a number of native methods.
+  * Fix range checking for `GRand' methods.
+  * Fix crash when deleting natively implemented object attributes.
+  * Fix bug which assigned the wrong hash to bytestrings.
+  * Fix `__int__' methods to return `long' objects when necessary.
+    Without this, there are unnecessary failures and bizarrely timed
+    exceptions.
+  * A couple of patches to provide forward compatibility with upstream
+    library changes.
+
+ -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:25:35 +0100
+
 catacomb-python (1.1.1) experimental; urgency=low
 
   * ByteString operators: fix crashes on 64-bit platforms resulting from