chiark / gitweb /
t/: Add a test suite.
[catacomb-python] / debian / rules
index 94c8a3115983602f2f9bf730f4e98252feef7312..04d6f4e8b376da299045278a57f866aba6be7a5d 100755 (executable)
@@ -1,67 +1,10 @@
 #! /usr/bin/make -f
+%:; dh $@ --parallel --with python2
 
-export DH_COMPAT = 4
+export PYTHONS := $(shell pyversions -r)
 
-DEFVERSION = 2.3
-VERSIONS = $(DEFVERSION) 2.4
-
-build: build-stamp
-
-build-stamp:
-       for v in $(VERSIONS); do python$$v setup.py build; done
-       touch build-stamp
-
-clean:
-       dh_clean
-       rm -rf build build-stamp
-
-install: build
-       dh_clean
-       for v in $(VERSIONS); do \
-         python$$v setup.py build; \
-         python$$v setup.py install --root=debian/python$$v-catacomb; \
-       done
-       mkdir -p debian/python-catacomb
-       mkdir -p debian/python-catacomb-bin/usr/bin
-       mv debian/python$(DEFVERSION)-catacomb/usr/bin/* \
-         debian/python-catacomb-bin/usr/bin
-       for v in $(VERSIONS); do \
-         rm -rf debian/python$$v-catacomb/usr/bin; \
-       done
-
-binary-indep: install
-       dh_testdir -i
-       dh_testroot -i
-       dh_compress -i
-       dh_installdocs -i
-       dh_gencontrol -i
-       dh_fixperms -i
-       dh_installdeb -i
-       dh_md5sums -i
-       dh_builddeb -i
-
-binary-arch: install
-       dh_testdir -a
-       dh_testroot -a
-       dh_compress -a
-       dh_installdocs -a
-       dh_strip -a
-       dh_shlibdeps -a
-       dh_gencontrol -a
-       dh_fixperms -a
-       dh_installdeb -a
-       dh_md5sums -a
-       dh_builddeb -a
-
-binary: binary-indep binary-arch
-
-source:
-       rm -rf dist/*.tar.gz dist/=deb=
-       python$(DEFVERSION) setup.py sdist
-       mkdir dist/=deb=
-       cd dist/=deb=; tar xvfz ../*.tar.gz
-       d=`pwd`; cd ..; dpkg-source -i -i'/\.svn/' -b $$d/dist/=deb=/*
-       rm -rf dist/=deb=
-
-.PHONY: binary binary-arch binary-indep clean install source build
+override_dh_auto_test:
+       dh_auto_test -- OPTS-check=-V
 
+override_dh_auto_install:
+       dh_auto_install -- prefix=/usr