chiark / gitweb /
Debian build: Fix .so symlinks
[wiringPi.git] / debian / rules
index 423a47316d1eb6100eba27e52f8888ef98606d38..53337619c46a12bfd1644fc3290c831a62ecf361 100755 (executable)
@@ -37,6 +37,8 @@ override_dh_auto_build: dirs
            bash -xe ./build
 
 override_dh_auto_install:
+
+override_dh_install:
        dh_install
        set -ex; for l in libwiringPi libwiringPiDev; do \
                ln -sf $$l.so.$${VERSION} \
@@ -45,5 +47,11 @@ override_dh_auto_install:
                        debian/libwiringpi-dev/usr/lib/$$l.so; \
        done
 
+override_dh_fixperms:
+       dh_fixperms
+       set -e; b=debian/wiringpi-tools/usr/bin/gpio; \
+       chown root.root $$b; \
+       chmod 4755 $$b
+
 %:
        dh $@