chiark / gitweb /
Debian build: Install `gpio' setuid root, and world-executable.
[wiringPi.git] / debian / rules
index 423a47316d1eb6100eba27e52f8888ef98606d38..53779184b14c09c4754038168fd9dc4283caade1 100755 (executable)
@@ -45,5 +45,11 @@ override_dh_auto_install:
                        debian/libwiringpi-dev/usr/lib/$$l.so; \
        done
 
+override_dh_fixperms:
+       dh_fixperms
+       set -e; b=debian/wiringpi-tools/usr/bin/gpio; \
+       chown root.root $$b; \
+       chmod 4755 $$b
+
 %:
        dh $@