chiark / gitweb /
Build system: debian/rules: Do not run build for *-indep (!)
[secnet.git] / debian / changelog
index ded7d3dec3efe9cb93ef10dd4bd99b3e84a0d5ef..6e5478508092285ca7a553f6d375947543d45b7a 100644 (file)
@@ -1,3 +1,85 @@
+secnet (0.4.0~beta2~) unstable; urgency=low
+
+  * polypath: Ignore IPv6 Unique Local unicast addresses.
+  * polypath: Skip "tentative" IPv6 local addresses.
+  * polypath: Improve logging and debug output.
+  * Portability fix: Build where size_t is not compatible with int.
+  * Makefile: support DESTDIR.
+  * debian/rules: set DESTDIR (not prefix).
+  * Do not install ipaddrset.py and secnet.8 executable.
+  * Fix check for <linux/if_tun.h>.
+  * debian/rules: Support dpkg-buildflags.
+
+  Copyright updates:
+  * Update to GPLv3.  Add missing copyright notices and credits.
+  * Get rid of old FSF street address; use URL instead.
+  * Remove obsolete LICENCE.txt (which was for snprintf reimplementation).
+  * Remove obsolete references to Cendio (for old ipaddr.py).
+  * Build system: debian/rules: Provide build-arch and build-indep targets.
+  * Build system: debian/rules: Do not run build for *-indep (!)
+
+ --
+
+secnet (0.4.0~beta1) unstable; urgency=low
+
+  New features:
+  * Support transport over IPv6.  (We do not yet carry IPv6 in the private
+    network.)  IPv6 support depends on IPv6-capable adns (adns 1.5.x).
+  * New polypath comm, which can duplicate packets so as to send them via
+    multiple routes over the public network, for increased
+    reliability/performance (but increased cost).  Currently Linux-only
+    but should be fairly easy to port.
+  * Support multiple public addresses for peers.
+  * Discard previously-received packets (by default).
+
+  Logging improvements:
+  * Report (each first) transmission and reception success and failure.
+  * Log reason for DNS reolution failure.
+  * Log unexpected kinds of death from userv.
+  * Log authbind exit status as errno value (if appropriate).
+
+  Configuration adjustments:
+  * Adjust default number of mobile peer addresses to store when a peer
+    public address is also configured.
+  * Make specifying peer public port optional.  This avoids making special
+    arrangements to bind to a port for in mobile sites with no public
+    stable address.
+
+  Bugfixes:
+  * Hackypar children will die if they get a terminating signal.
+  * Fix signal dispositions inherited by secnet's child processes.
+  * Fix off-by-one error which prevented setting transport-peers-max to 5.
+
+  Test, build and internal improvements:
+  * Use conventional IP address handling library ipaddr.py.
+  * Provide a fuzzer for the slip decoder.
+  * Build system improvements.
+  * Many source code cleanups.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 26 Oct 2014 15:28:31 +0000
+
+secnet (0.3.4) unstable; urgency=low
+
+  SECURITY FIX:
+  * The previous security fix to buffer handling was entirely wrong.  This
+    one is better.  Thanks to Simon Tatham for the report and the patch.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Mon, 22 Sep 2014 16:16:11 +0100
+
+secnet (0.3.3) unstable; urgency=high
+
+  SECURITY FIXES:
+  * Pass correct size argument to recvfrom.  This is a serious security
+    problem which may be exploitable from outside the VPN.
+  * Fix a memory leak in some error logging.
+
+  Other related fixes:
+  * Two other latent bugs in buffer length handling found and fixed.
+  * Non-critical stylistic improvements to buffer length handling, to make
+    the code clearer and to assist audit.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Fri, 19 Sep 2014 23:50:45 +0100
+
 secnet (0.3.3~beta1) unstable; urgency=low
 
   Installation compatibility fix: