chiark / gitweb /
Use deterministic test seed
[nlopt.git] / test / CMakeLists.txt
index 224ac9c145d8c8feaf30b4a3e3c2b76650d58ae6..4154eb90000d7385ec71cae6960bbcdc3fc77a96 100644 (file)
@@ -32,8 +32,8 @@ foreach (algo_index RANGE 29)# 43
       set (enable_ FALSE)
     endif ()
     if (enable_)
-      add_test (NAME testopt_algo${algo_index}_obj${obj_index} COMMAND testopt -a ${algo_index} -o ${obj_index})
-      if (WIN32)
+      add_test (NAME testopt_algo${algo_index}_obj${obj_index} COMMAND testopt -r 0 -a ${algo_index} -o ${obj_index})
+      if (CMAKE_HOST_SYSTEM_NAME MATCHES Windows)
         set_tests_properties (testopt_algo${algo_index}_obj${obj_index} PROPERTIES ENVIRONMENT "PATH=${PROJECT_BINARY_DIR}\\${CMAKE_BUILD_TYPE};$ENV{PATH}")  # to load dll
       endif ()
     endif ()