chiark / gitweb /
[PATCH] update the udev.spec to add udevtest and make some more Red Hat suggested...
[elogind.git] / udev.spec
index b622237e6735248d74c308480b7e13edf0da02e5..aa595962f7dbcc29690c00039c217e1a87e9aba4 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 %define debug 0
 
 # if we want to use the LSB version of the init script or the Redhat one
-# 0 - use Redhat version: etc/init.d/udev
-# 1 - use LSB version: etc/init.d/udev.init.LSB
+# 0 - use Redhat: etc/init.d/udev
+# 1 - use LSB: etc/init.d/udev.init.LSB
 %define lsb 0
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 014_bk
+Version: 017_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -54,21 +54,32 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %endif
 %if %{log}
        USE_LOG=true            \
+%else
+       USE_LOG=false           \
 %endif
 %if %{dbus}
        USE_DBUS=true           \
+%else
+       USE_DBUS=false          \
 %endif
 %if %{debug}
        DEBUG=true              \
+%else
+       DEBUG=false             \
 %endif
 
+
 %install
 make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{dbus}
-       USE_DBUS=true
+       USE_DBUS=true           \
+%else
+       USE_DBUS=false          \
 %endif
 %if %{lsb}
-       USE_LSB=true
+       USE_LSB=true            \
+%else
+       USE_LSB=false           \
 %endif
 
 %post
@@ -87,8 +98,11 @@ rm -rf $RPM_BUILD_ROOT
 %doc COPYING README TODO ChangeLog
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /sbin/udevinfo
-%attr(755,root,root) /udev/
-%attr(755,root,root) /etc/udev/
+%attr(755,root,root) /sbin/udevsend
+%attr(755,root,root) /sbin/udevd
+%attr(755,root,root) /sbin/udevtest
+%attr(755,root,root) %dir /udev/
+%attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
@@ -100,6 +114,18 @@ rm -rf $RPM_BUILD_ROOT
 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
 
 %changelog
+* Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
+- fix up udevd build, as it's no longer needed to be build seperatly
+- add udevtest to list of files
+- more Red Hat sync ups.
+
+* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some changes from the latest Fedora udev release.
+
+* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add udevsend, and udevd to the files
+- add ability to build udevd with glibc after the rest is build with klibc
+
 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
 - added udevinfo to rpm
 - added URL to spec file