chiark / gitweb /
[PATCH] update the udev.spec to add udevtest and make some more Red Hat suggested...
[elogind.git] / udev.spec
index 9b5ef54cefab823c736159a4b3640f5517f92dda..aa595962f7dbcc29690c00039c217e1a87e9aba4 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -5,6 +5,12 @@
 # it probably is not where you want it to be.
 %define klibc 1
 
+# if we want to have logging support in or not.
+# 0 - no logging  support
+# 1 - logging support
+# Note, it is not recommend if you use klibc to enable logging.
+%define log 0
+
 # if we want to build DBUS support in or not.
 # 0 - no DBUS support
 # 1 - DBUS support
 # 1 - debugging enabled
 %define debug 0
 
+# if we want to use the LSB version of the init script or the Redhat one
+# 0 - use Redhat: etc/init.d/udev
+# 1 - use LSB: etc/init.d/udev.init.LSB
+%define lsb 0
+
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 011_bk
+Version: 017_bk
 Release: 1
 License: GPL
 Group: Utilities/System
 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
 ExclusiveOS: Linux
 Vendor: Greg Kroah-Hartman <greg@kroah.com>
+URL : kernel.org/pub/linux/utils/kernel/hotplug/
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Prereq: /bin/sh, fileutils, hotplug
 
@@ -40,17 +52,34 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %if %{klibc}
        USE_KLIBC=true          \
 %endif
+%if %{log}
+       USE_LOG=true            \
+%else
+       USE_LOG=false           \
+%endif
 %if %{dbus}
        USE_DBUS=true           \
+%else
+       USE_DBUS=false          \
 %endif
 %if %{debug}
        DEBUG=true              \
+%else
+       DEBUG=false             \
 %endif
 
+
 %install
 make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{dbus}
-       USE_DBUS=true
+       USE_DBUS=true           \
+%else
+       USE_DBUS=false          \
+%endif
+%if %{lsb}
+       USE_LSB=true            \
+%else
+       USE_LSB=false           \
 %endif
 
 %post
@@ -68,8 +97,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(-,root,root)
 %doc COPYING README TODO ChangeLog
 %attr(755,root,root) /sbin/udev
-%attr(755,root,root) /udev/
-%attr(755,root,root) /etc/udev/
+%attr(755,root,root) /sbin/udevinfo
+%attr(755,root,root) /sbin/udevsend
+%attr(755,root,root) /sbin/udevd
+%attr(755,root,root) /sbin/udevtest
+%attr(755,root,root) %dir /udev/
+%attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
@@ -78,9 +111,29 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
-%attr(0644,root,root) %{_mandir}/man8/udev.8*
+%attr(0644,root,root) %{_mandir}/man8/udev*.8*
 
 %changelog
+* Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
+- fix up udevd build, as it's no longer needed to be build seperatly
+- add udevtest to list of files
+- more Red Hat sync ups.
+
+* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some changes from the latest Fedora udev release.
+
+* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add udevsend, and udevd to the files
+- add ability to build udevd with glibc after the rest is build with klibc
+
+* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added udevinfo to rpm
+- added URL to spec file
+- added udevinfo's man page
+
+* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
+- add defines to choose the init script (Redhat or LSB)
+
 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
 - install the initscript and run chkconfig on it
 
@@ -96,4 +149,3 @@ rm -rf $RPM_BUILD_ROOT
 
 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
 - Initial spec file for udev-0.2.
-