chiark / gitweb /
[PATCH] 056 release
[elogind.git] / udev.spec
index cacaf2868a1758a5ff5e8653936b2a8f7518e1b8..a9d1c5fb227f6b18e1be9b685c6db9c836805361 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - debugging enabled
 %define debug 0
 
-# if we want to build the DBUS "extra" package or not
-# 0 - no DBUS support
-# 1 - DBUS support
-%define dbus 0
-
-# if we want to build the SELinux "extra" package or not
-# 0 - no SELinux support
-# 1 - SELinux support
-%define selinux 0
-
 # if we want to build the scsi_id "extra" package or not
 # 0 - do not build the package
 # 1 - build it
 %define scsi_id 1
 
+# if we want to build the volume_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define volume_id 1
+
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 024
+Version: 056
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -71,25 +66,20 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
-%if %{dbus}
-       extras/dbus     \
-%endif
-%if %{selinux}
-       extras/selinux  \
+%if %{volume_id}
+       extras/volume_id        \
 %endif
 "
 
 %install
+rm -rf $RPM_BUILD_ROOT
 make DESTDIR=$RPM_BUILD_ROOT install \
        EXTRAS="        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
-%if %{dbus}
-       extras/dbus     \
-%endif
-%if %{selinux}
-       extras/selinux  \
+%if %{volume_id}
+       extras/volume_id        \
 %endif
 "
 
@@ -108,7 +98,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(-,root,root)
 %doc COPYING README TODO ChangeLog HOWTO* docs/*
 %doc etc/udev/udev.rules.{examples,gentoo,redhat}
-%doc etc/udev/udev.permissions.{gentoo,redhat}
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /usr/bin/udevinfo
 %attr(755,root,root) /sbin/udevsend
@@ -118,23 +107,29 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %dir /udev/
 %attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
-%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
+%attr(755,root,root) %dir /etc/udev/rules.d/
+%config(noreplace) %attr(0644,root,root) /etc/udev/rules.d/50-udev.rules
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
-
-%if %{dbus}
-       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
-%endif
+%attr(755,root,root) %dir /etc/dev.d/
+%attr(755,root,root) %dir /etc/dev.d/net/
+%attr(0755,root,root) /etc/dev.d/net/hotplug.dev
 
 %if %{scsi_id}
        %attr(755,root,root) /sbin/scsi_id
        %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
        %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
 %endif
+%if %{volume_id}
+       %attr(755,root,root) /sbin/udev_volume_id
+%endif
 
 %changelog
+* Fri May 14 2004 Greg Kroah-Hartman <greg@kroah.com>
+- remove dbus and selinux stuff from here
+- added volume_id option
+
 * Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
 - change the way dbus and selinux support is built (now an extra)