chiark / gitweb /
[PATCH] add ability to install udevtest to Makefile
[elogind.git] / udev.spec
index 2be4496f403881e499485b83375002892aff1fe8..a53a1ad63b05427b55dbca8f3ac04f0c67706d85 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 014_bk
+Version: 017
 Release: 1
 License: GPL
 Group: Utilities/System
 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
 ExclusiveOS: Linux
 Vendor: Greg Kroah-Hartman <greg@kroah.com>
+URL : kernel.org/pub/linux/utils/kernel/hotplug/
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Prereq: /bin/sh, fileutils, hotplug
 
@@ -53,14 +54,24 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %endif
 %if %{log}
        USE_LOG=true            \
+%else
+       USE_LOG=false           \
 %endif
 %if %{dbus}
        USE_DBUS=true           \
+%else
+       USE_DBUS=false          \
 %endif
 %if %{debug}
        DEBUG=true              \
+%else
+       DEBUG=false             \
 %endif
 
+# now build udevd on it's own, as it can't handle being built with klibc
+make CC="gcc $RPM_OPT_FLAGS" udevd
+
+
 %install
 make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{dbus}
@@ -69,7 +80,6 @@ make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{lsb}
        USE_LSB=true
 %endif
-
 %post
 /sbin/chkconfig --add udev
 
@@ -86,8 +96,11 @@ rm -rf $RPM_BUILD_ROOT
 %doc COPYING README TODO ChangeLog
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /sbin/udevinfo
+%attr(755,root,root) /sbin/udevsend
+%attr(755,root,root) /sbin/udevd
 %attr(755,root,root) /udev/
 %attr(755,root,root) /etc/udev/
+%attr(755,root,root) %dir
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
@@ -96,11 +109,20 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
-%attr(0644,root,root) %{_mandir}/man8/udev.8*
+%attr(0644,root,root) %{_mandir}/man8/udev*.8*
 
 %changelog
+* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some changes from the latest Fedora udev release.
+
+* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add udevsend, and udevd to the files
+- add ability to build udevd with glibc after the rest is build with klibc
+
 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
-- add udevinfo to rpm
+- added udevinfo to rpm
+- added URL to spec file
+- added udevinfo's man page
 
 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
 - add defines to choose the init script (Redhat or LSB)