chiark / gitweb /
[PATCH] fix dbus build in the udev.spec file.
[elogind.git] / udev.spec
index 49b8b131dab40392490f3dbdf6e6aec37b36f83f..a0cd75a608600a727e55c836e3e0250ebe9408f6 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # Note, it is not recommend if you use klibc to enable logging.
 %define log 0
 
-# if we want to build DBUS support in or not.
-# 0 - no DBUS support
-# 1 - DBUS support
-%define dbus 0
-
 # if we want to build SELinux support in or not.
 # 0 - no SELinux support
 # 1 - SELinux support
-%define selinux 
+%define selinux 0
 
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 1 - debugging enabled
 %define debug 0
 
+# if we want to build the DBUS "extra package or not
+# 0 - no DBUS support
+# 1 - DBUS support
+%define dbus 0
+
 # if we want to build the scsi_id "extra" package or not
 # 0 - do not build the package
 # 1 - build it
@@ -34,7 +34,7 @@
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 019_bk
+Version: 022_bk
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -62,11 +62,6 @@ make CC="gcc $RPM_OPT_FLAGS" \
 %else
        USE_LOG=false           \
 %endif
-%if %{dbus}
-       USE_DBUS=true           \
-%else
-       USE_DBUS=false          \
-%endif
 %if %{selinux}
        USE_SELINUX=true        \
 %else
@@ -81,15 +76,13 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
+%if %{dbus}
+       extras/dbus     \
+%endif
 "
 
 %install
 make DESTDIR=$RPM_BUILD_ROOT install \
-%if %{dbus}
-       USE_DBUS=true           \
-%else
-       USE_DBUS=false          \
-%endif
 %if %{selinux}
        USE_SELINUX=true        \
 %else
@@ -99,6 +92,9 @@ make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{scsi_id}
        extras/scsi_id  \
 %endif
+%if %{dbus}
+       extras/dbus     \
+%endif
 "
 
 %post
@@ -114,9 +110,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc COPYING README TODO ChangeLog HOWTO* etc/udev/udev.rules.examples docs/*
+%doc COPYING README TODO ChangeLog HOWTO* docs/*
+%doc etc/udev/udev.rules.{examples,gentoo,redhat}
+%doc etc/udev/udev.permissions.{gentoo,redhat}
 %attr(755,root,root) /sbin/udev
-%attr(755,root,root) /sbin/udevinfo
+%attr(755,root,root) /usr/bin/udevinfo
 %attr(755,root,root) /sbin/udevsend
 %attr(755,root,root) /sbin/udevd
 %attr(755,root,root) /sbin/udevtest
@@ -141,8 +139,12 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %changelog
+* Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
+- change the way dbus support is built (now an extra)
+
 * Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
 - added udevstart to the list of files installed
+- udevinfo is now in /usr/bin not /sbin
 
 * Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
 - added ability to build with SELinux support