chiark / gitweb /
[PATCH] add IGNORE rule type
[elogind.git] / udev.spec
index fd6b488aeb6975d46395442cb739c0a55b5fbfbd..9e301deb7c552ade47d3d83bcbe917c937a3198a 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -1,13 +1,31 @@
+# if we want to build against the included version of klibc or not.
+# 0 - do not use klibc
+# 1 - use klibc
+# Watch out for where the linux symlink is in the klibc part of the tarball,
+# it probably is not where you want it to be.
+%define klibc 1
+
+# if we want to build DBUS support in or not.
+# 0 - no DBUS support
+# 1 - DBUS support
+%define dbus 0
+
+# if we want to enable debugging support in udev.  If it is enabled, lots of 
+# stuff will get sent to the debug syslog.
+# 0 - debugging disabled
+# 1 - debugging enabled
+%define debug 0
+
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 004_bk
+Version: 012_bk
 Release: 1
 License: GPL
 Group: Utilities/System
 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
 ExclusiveOS: Linux
 Vendor: Greg Kroah-Hartman <greg@kroah.com>
-BuildRoot: /var/tmp/%{name}-%{version}-%{release}-root
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Prereq: /bin/sh, fileutils, hotplug
 
 %description
@@ -18,28 +36,57 @@ udev is a implementation of devfs in userspace using sysfs and
 %setup -q
 
 %build
-make CC="gcc $RPM_OPT_FLAGS"
+make CC="gcc $RPM_OPT_FLAGS"   \
+%if %{klibc}
+       USE_KLIBC=true          \
+%endif
+%if %{dbus}
+       USE_DBUS=true           \
+%endif
+%if %{debug}
+       DEBUG=true              \
+%endif
 
 %install
-make prefix=$RPM_BUILD_ROOT install
-rm -f ${RPM_BUILD_ROOT}/etc/hotplug.d/default/udev.hotplug
-ln -s /sbin/udev ${RPM_BUILD_ROOT}/etc/hotplug.d/default/udev.hotplug
+make DESTDIR=$RPM_BUILD_ROOT install \
+%if %{dbus}
+       USE_DBUS=true
+%endif
+
+%post
+/sbin/chkconfig --add udev
+
+%postun
+if [ $1 = 0 ]; then
+       /sbin/chkconfig --del udev
+fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(0644,root,root)
+%defattr(-,root,root)
 %doc COPYING README TODO ChangeLog
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /udev/
 %attr(755,root,root) /etc/udev/
-%attr(0644,root,root) /etc/udev/namedev.config
-%attr(0644,root,root) /etc/udev/namedev.permissions
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
+%if %{dbus}
+       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
+%endif
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
+%attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev.8*
 
 %changelog
+* Tue Dec 16 2003 Robert Love <rml@ximian.com>
+- install the initscript and run chkconfig on it
+
+* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
+- changes due to config file name changes
+
 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
 - Make work without a build root
 - Correctly install the right files