chiark / gitweb /
[PATCH] 018 release
[elogind.git] / udev.spec
index aa595962f7dbcc29690c00039c217e1a87e9aba4..92a2911711ca79d000a5c3aa27c35031fb9675a0 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - DBUS support
 %define dbus 0
 
+# if we want to build SELinux support in or not.
+# 0 - no SELinux support
+# 1 - SELinux support
+%define selinux 1 
+
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 0 - debugging disabled
 # 1 - use LSB: etc/init.d/udev.init.LSB
 %define lsb 0
 
+# if we want to build the scsi_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define scsi_id 1
+
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 017_bk
+Version: 019
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -62,12 +72,21 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %else
        USE_DBUS=false          \
 %endif
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
+%endif
 %if %{debug}
        DEBUG=true              \
 %else
        DEBUG=false             \
 %endif
-
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
+%endif
+"
 
 %install
 make DESTDIR=$RPM_BUILD_ROOT install \
@@ -76,11 +95,21 @@ make DESTDIR=$RPM_BUILD_ROOT install \
 %else
        USE_DBUS=false          \
 %endif
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
+%endif
 %if %{lsb}
        USE_LSB=true            \
 %else
        USE_LSB=false           \
 %endif
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
+%endif
+"
 
 %post
 /sbin/chkconfig --add udev
@@ -95,7 +124,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc COPYING README TODO ChangeLog
+%doc COPYING README TODO ChangeLog HOWTO* etc/udev/udev.rules.examples docs/*
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /sbin/udevinfo
 %attr(755,root,root) /sbin/udevsend
@@ -106,14 +135,28 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
-%if %{dbus}
-       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
-%endif
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
 %attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
 
+%if %{dbus}
+       %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
+%endif
+
+%if %{scsi_id}
+       %attr(755,root,root) /sbin/scsi_id
+       %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
+       %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
+%endif
+
 %changelog
+* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added ability to build with SELinux support
+
+* Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some more files to the documentation directory
+- add ability to build scsi_id and make it the default
+
 * Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
 - fix up udevd build, as it's no longer needed to be build seperatly
 - add udevtest to list of files