chiark / gitweb /
[PATCH] 018 release
[elogind.git] / udev.spec
index 553e58a7837d8e9678bdb199b4f7956b7233ec3b..92a2911711ca79d000a5c3aa27c35031fb9675a0 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - DBUS support
 %define dbus 0
 
+# if we want to build SELinux support in or not.
+# 0 - no SELinux support
+# 1 - SELinux support
+%define selinux 1 
+
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 0 - debugging disabled
@@ -34,7 +39,7 @@
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 017_bk
+Version: 019
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -67,6 +72,11 @@ make CC="gcc $RPM_OPT_FLAGS" \
 %else
        USE_DBUS=false          \
 %endif
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
+%endif
 %if %{debug}
        DEBUG=true              \
 %else
@@ -85,6 +95,11 @@ make DESTDIR=$RPM_BUILD_ROOT install \
 %else
        USE_DBUS=false          \
 %endif
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
+%endif
 %if %{lsb}
        USE_LSB=true            \
 %else
@@ -135,6 +150,9 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %changelog
+* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added ability to build with SELinux support
+
 * Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
 - add some more files to the documentation directory
 - add ability to build scsi_id and make it the default