chiark / gitweb /
[PATCH] make spec file turn off selinux support by default.
[elogind.git] / udev.spec
index b9a20ac5fd9f74485d86001e6ed577bd55afb5b6..9289a84e60d9c305cbf60d4c3c9a8c568565a1da 100644 (file)
--- a/udev.spec
+++ b/udev.spec
 # 1 - DBUS support
 %define dbus 0
 
+# if we want to build SELinux support in or not.
+# 0 - no SELinux support
+# 1 - SELinux support
+%define selinux 0
+
 # if we want to enable debugging support in udev.  If it is enabled, lots of 
 # stuff will get sent to the debug syslog.
 # 0 - debugging disabled
 # 1 - debugging enabled
 %define debug 0
 
-# if we want to use the LSB version of the init script or the Redhat one
-# 0 - use Redhat version: etc/init.d/udev
-# 1 - use LSB version: etc/init.d/udev.init.LSB
-%define lsb 0
+# if we want to build the scsi_id "extra" package or not
+# 0 - do not build the package
+# 1 - build it
+%define scsi_id 1
 
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 014_bk
+Version: 020
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -54,22 +59,47 @@ make CC="gcc $RPM_OPT_FLAGS"        \
 %endif
 %if %{log}
        USE_LOG=true            \
+%else
+       USE_LOG=false           \
 %endif
 %if %{dbus}
        USE_DBUS=true           \
+%else
+       USE_DBUS=false          \
+%endif
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
 %endif
 %if %{debug}
        DEBUG=true              \
+%else
+       DEBUG=false             \
+%endif
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
 %endif
+"
 
 %install
 make DESTDIR=$RPM_BUILD_ROOT install \
 %if %{dbus}
-       USE_DBUS=true
+       USE_DBUS=true           \
+%else
+       USE_DBUS=false          \
+%endif
+%if %{selinux}
+       USE_SELINUX=true        \
+%else
+       USE_SELINUX=false       \
 %endif
-%if %{lsb}
-       USE_LSB=true
+       EXTRAS="        \
+%if %{scsi_id}
+       extras/scsi_id  \
 %endif
+"
 
 %post
 /sbin/chkconfig --add udev
@@ -84,25 +114,59 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%doc COPYING README TODO ChangeLog
+%doc COPYING README TODO ChangeLog HOWTO* etc/udev/udev.rules.examples docs/*
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /sbin/udevinfo
-%attr(755,root,root) /udev/
-%attr(755,root,root) /etc/udev/
+%attr(755,root,root) /sbin/udevsend
+%attr(755,root,root) /sbin/udevd
+%attr(755,root,root) /sbin/udevtest
+%attr(755,root,root) /sbin/udevstart
+%attr(755,root,root) %dir /udev/
+%attr(755,root,root) %dir /etc/udev/
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
+%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
+%attr(755,root,root) /etc/init.d/udev
+%attr(0644,root,root) %{_mandir}/man8/udev*.8*
+
 %if %{dbus}
        %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
 %endif
-%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
-%attr(755,root,root) /etc/init.d/udev
-%attr(0644,root,root) %{_mandir}/man8/udev.8*
+
+%if %{scsi_id}
+       %attr(755,root,root) /sbin/scsi_id
+       %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
+       %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
+%endif
 
 %changelog
+* Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added udevstart to the list of files installed
+
+* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
+- added ability to build with SELinux support
+
+* Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some more files to the documentation directory
+- add ability to build scsi_id and make it the default
+
+* Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
+- fix up udevd build, as it's no longer needed to be build seperatly
+- add udevtest to list of files
+- more Red Hat sync ups.
+
+* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add some changes from the latest Fedora udev release.
+
+* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
+- add udevsend, and udevd to the files
+- add ability to build udevd with glibc after the rest is build with klibc
+
 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
-- add udevinfo to rpm
+- added udevinfo to rpm
 - added URL to spec file
+- added udevinfo's man page
 
 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
 - add defines to choose the init script (Redhat or LSB)