chiark / gitweb /
[PATCH] patch udev 009-010 rpm spec file
[elogind.git] / udev.spec
index ffdfb2470d0c2c6a7a5b0d5a11043b2506a7f2b6..6530c557c769fb92961e9791a0bfdf4c9cf88c56 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -1,13 +1,13 @@
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 004_bk
+Version: 010
 Release: 1
 License: GPL
 Group: Utilities/System
 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
 ExclusiveOS: Linux
 Vendor: Greg Kroah-Hartman <greg@kroah.com>
-BuildRoot: /var/tmp/%{name}-%{version}-%{release}-root
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Prereq: /bin/sh, fileutils, hotplug
 
 %description
@@ -21,25 +21,39 @@ udev is a implementation of devfs in userspace using sysfs and
 make CC="gcc $RPM_OPT_FLAGS"
 
 %install
-make prefix=$RPM_BUILD_ROOT install
-rm -f ${RPM_BUILD_ROOT}/etc/hotplug.d/default/udev.hotplug
-ln -s /sbin/udev ${RPM_BUILD_ROOT}/etc/hotplug.d/default/udev.hotplug
+make DESTDIR=$RPM_BUILD_ROOT install
+
+%post
+/sbin/chkconfig --add udev
+
+%postun
+if [ $1 = 0 ]; then
+       /sbin/chkconfig --del udev
+fi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(0644,root,root)
+%defattr(-,root,root)
 %doc COPYING README TODO ChangeLog
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /udev/
 %attr(755,root,root) /etc/udev/
-%attr(0644,root,root) /etc/udev/udev.config
-%attr(0644,root,root) /etc/udev/udev.permissions
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
+%attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev.8*
 
 %changelog
+* Tue Dec 16 2003 Robert Love <rml@ximian.com>
+- install the initscript and run chkconfig on it
+
+* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
+- changes due to config file name changes
+
 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
 - Make work without a build root
 - Correctly install the right files