chiark / gitweb /
[PATCH] patch udev 009-010 rpm spec file
[elogind.git] / udev.spec
index 8cc424cacb9b48eb381aac6b3f2f797ba1555659..6530c557c769fb92961e9791a0bfdf4c9cf88c56 100644 (file)
--- a/udev.spec
+++ b/udev.spec
@@ -1,6 +1,6 @@
 Summary: A userspace implementation of devfs
 Name: udev
-Version: 007_bk
+Version: 010
 Release: 1
 License: GPL
 Group: Utilities/System
@@ -23,22 +23,34 @@ make CC="gcc $RPM_OPT_FLAGS"
 %install
 make DESTDIR=$RPM_BUILD_ROOT install
 
+%post
+/sbin/chkconfig --add udev
+
+%postun
+if [ $1 = 0 ]; then
+       /sbin/chkconfig --del udev
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(0644,root,root)
+%defattr(-,root,root)
 %doc COPYING README TODO ChangeLog
 %attr(755,root,root) /sbin/udev
 %attr(755,root,root) /udev/
 %attr(755,root,root) /etc/udev/
-%attr(0644,root,root) /etc/udev/udev.conf
-%attr(0644,root,root) /etc/udev/udev.rules
-%attr(0644,root,root) /etc/udev/udev.permissions
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
+%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
+%attr(755,root,root) /etc/init.d/udev
 %attr(0644,root,root) %{_mandir}/man8/udev.8*
 
 %changelog
+* Tue Dec 16 2003 Robert Love <rml@ximian.com>
+- install the initscript and run chkconfig on it
+
 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
 - changes due to config file name changes